router1:<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Press Enter to Start

Router>

Router>en

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host router1

router1(config)#int s0

router1(config-if)#encapsulation frame-relay

router1(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial0, changed state to up

%LINK-3-UPDOWN: Interface Serial0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

router1(config-if)# int s0.0 multi-point

router1(config-subif)#ip add 172.16.1.1 255.255.255.0

router1(config-subif)#frame-relay interface-dlci 102

router1(config-subif)#frame-relay interface-dlci 103

router1(config-subif)#frame-relay inverse-arp

router1(config-subif)#

router1(config-subif)#

%LINK-3-UPDOWN: Interface Serial0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 103 state changed to ACTIVE

router1(config-subif)#

router1(config-subif)#end

router1#sh fr map

Serial0.0 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast

        status defined, active

 (up): point-to-point dlci, dlci 103(0x66,0x1860), broadcast

        status defined, active

 

router1#

router1#ping 172.16.1.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />1/2/4 ms

router1#ping 172.16.1.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

router1#

router1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router1(config)#int e0

router1(config-if)#ip add 192.168.1.1 255.255.255.0

router1(config-if)#no shut

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

router1(config-if)#exit

router1(config)#router rip

router1(config-router)#version 2

router1(config-router)#network 192.168.1.0

router1(config-router)#network 172.16.1.0

router1(config-router)#end

 

 

router2:

Press Enter to Start

Router>en

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host router2

router2(config)#int s0

router2(config-if)#encapsulation frame-relay

router2(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial0, changed state to up

router2(config-if)#int s0.0 multi-point

router2(config-subif)#ip add 172.16.1.2 255.255.255.0

router2(config-subif)#frame-relay interface-dlci 201

21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 201 state changed to ACTIVE

router2(config-subif)#frame-relay inverse-arp

router2(config-subif)#

router2(config-subif)#end

router2#sh fr map

Serial0.0 (up): point-to-point dlci, dlci 201(0x66,0x1860), broadcast

        status defined, active

 

router2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router2(config)#int e0

router2(config-if)#ip add 192.168.2.1 255.255.255.0

router2(config-if)#no shut

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

router2(config-if)#exit

router2(config)#router rip

router2(config-router)#version 2

router2(config-router)#network 172.16.1.0

router2(config-router)#network 192.168.2.0

router2(config-router)#end

 

router2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

       U - per-user static route

 

Gateway of last resort is not set

 

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, 172.16.1.2

C    192.168.2.0 is directly connected, Ethernet0

// router2 上配置好了动态路由之后,可是查看不到动态跌幅信息,我做了两三次都是这样,所以就加一条静态路由,如下……

router2#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router2(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.1

router2(config)#end

 

router2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

       U - per-user static route

 

Gateway of last resort is not set

 

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, 172.16.1.2

C    192.168.2.0 is directly connected, Ethernet0

S    192.168.1.0 [1/0] via 172.16.1.1

 

 

Router3:

Press Enter to Start

Router>

Router>en

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host router3

router3(config)#int s0

router3(config-if)#encapsulation frame-relay

router3(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial0, changed state to up

router3(config-if)#int s0.0 multi-point

router3(config-subif)#ip add 172.16.1.3 255.255.255.0

router3(config-subif)#frame-relay interface-dlci 301

21:49:39: %FR-5-DLCICHANGE: Interface Serial0.0 - DLCI 301 state changed to ACTIVE

router3(config-subif)#frame-relay inverse-arp

router3(config-subif)#

router3(config-subif)#end

router3#sh fr map

Serial0.0 (up): point-to-point dlci, dlci 301(0x66,0x1860), broadcast

        status defined, active

 

router3#

router3#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router3(config)#int e0

router3(config-if)#ip add 192.168.3.1 255.255.255.0

router3(config-if)#no shut

%LINK-3-UPDOWN: Interface Ethernet0, changed state to up

router3(config-if)#exit

router3(config)#router rip

router3(config-router)#version 2

router3(config-router)#network 192.168.3.0

router3(config-router)#network 172.16.1.0

router3(config-router)#end

router3#

router3#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

       U - per-user static route

 

Gateway of last resort is not set

 

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, 172.16.1.3

C    192.168.3.0 is directly connected, Ethernet0

R    192.168.1.0 [120/1] via 172.16.1.1, 00:01:42, Serial0.0

PC IP 地址和网关地址如下:

PC1:192.168.1.10/24   192.168.1.1

PC2:192.168.2.10/24   192.168.2.1

PC3:192.168.3.10/24    192.168.3.1

 

配置到此以后,PC1可以分别pingPC2PC3,但是PC2PC3之间无法通信,这是正常的,因为在他们之间没有建立PVC