POJ 2553 The Bottom of a Graph

The Bottom of a Graph
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 7514 Accepted: 3083

Description

We will use the following (standard) definitions from graph theory. Let  V be a nonempty and finite set, its elements being called vertices (or nodes). Let  E be a subset of the Cartesian product  V×V, its elements being called edges. Then  G=(V,E) is called a directed graph. 
Let  n be a positive integer, and let  p=(e1,...,en) be a sequence of length  n of edges  ei∈E such that  ei=(vi,vi+1) for a sequence of vertices  (v1,...,vn+1). Then  p is called a path from vertex  v1 to vertex  vn+1 in  G and we say that  vn+1 is reachable from  v1, writing  (v1→vn+1)
Here are some new definitions. A node  v in a graph  G=(V,E) is called a sink, if for every node  w in  G that is reachable from  vv is also reachable from  w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph  G. Each test case starts with an integer number  v, denoting the number of vertices of  G=(V,E), where the vertices will be identified by the integer numbers in the set  V={1,...,v}. You may assume that  1<=v<=5000. That is followed by a non-negative integer  e and, thereafter,  e pairs of vertex identifiers  v1,w1,...,ve,we with the meaning that  (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

Source

 
 
  1. 题目大意      若节点V所能到达的点{w},都能反过来到达v,那我们称v是sink。  
  2. 强连通+缩点  
  3. 就是求极大连通分量,最后统计出度为0的点,排序后输出初度为0的分量包含的每一个点。  
  4. 不管怎么样都会存在一个出度为0的点,所以说If the bottom is empty, print empty line是没有用的。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int VM=5010;
const int INF=999999999;

struct Edge{
    int to,nxt;
}edge[VM*VM];

int n,m,cnt,dep,top,atype,head[VM];
int dfn[VM],low[VM],vis[VM],indeg[VM],outdeg[VM],belong[VM];
int stack[VM],res[VM];

void addedge(int cu,int cv){
    edge[cnt].to=cv;
    edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

void Init(){
    cnt=0,atype=0,dep=0,top=0;
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(indeg,0,sizeof(indeg));
    memset(outdeg,0,sizeof(outdeg));
    memset(belong,0,sizeof(belong));
}

void Tarjan(int u){
    dfn[u]=low[u]=++dep;
    stack[top++]=u;
    vis[u]=1;
    for(int i=head[u];i!=-1;i=edge[i].nxt){
        int v=edge[i].to;
        if(!dfn[v]){
            Tarjan(v);
            low[u]=min(low[u],low[v]);
        }else if(vis[v])
            low[u]=min(low[u],dfn[v]);
    }
    int j;
    if(dfn[u]==low[u]){
        atype++;
        do{
            j=stack[--top];
            belong[j]=atype;
            vis[j]=0;
        }while(u!=j);
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n) && n){
        Init();
        scanf("%d",&m);
        int u,v;
        while(m--){
            scanf("%d%d",&u,&v);
            addedge(u,v);
        }
        for(int i=1;i<=n;i++)
            if(!dfn[i])
                Tarjan(i);
        int tmp;
        for(int i=1;i<=n;i++){
            tmp=belong[i];
            for(int j=head[i];j!=-1;j=edge[j].nxt){
                int v=edge[j].to;
                if(belong[i]!=belong[v])
                    outdeg[belong[i]]++;
            }
        }
        cnt=0;
        for(int i=1;i<=atype;i++)
            if(outdeg[i]==0)
                for(int j=1;j<=n;j++)
                    if(belong[j]==i)
                        res[cnt++]=j;
        sort(res,res+cnt);
        if(cnt!=0){
            for(int i=0;i<cnt-1;i++)
                printf("%d ",res[i]);
            printf("%d\n",res[cnt-1]);
        }else
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值