zoj 1004 Anagrams by Stack

Anagrams by Stack

Time Limit: 2 Seconds      Memory Limit: 65536 KB

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process

A stack is a data storage and retrieval structure permitting two operations:

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o ois valid, but
i i o is not (it's too short), neither is
i i o o o i(there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input
madam
adamm
bahama
bahama
long
short
eric
rice
Sample Output
[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]
题意概括:输入两个字符串,对比这两个字符串,看第一个字符串能否通过进栈出栈的方式与第二个字符串相吻合。如果可以,按字典序输出进栈出栈的过程。i表示进栈,o表示出栈。

解题思路:设置两个栈,一个用来储存字母;另一个用来储存i和o(即进栈与出栈)。用ipush和ipop分别表示进栈与出栈的次数。当ipush的值没有达到字符串的长度时,先让所有字母都进栈,通过dfs进行深度搜索,然后dfs后的语句为恢复为进栈前的样子。同样的方式来处理出栈。

AC代码:

#include<stdio.h>
#include<string.h>

int length;
char a[50], b[50], s1[100], s2[100];
int top1 = -1, top2 = -1;
void dfs(int ipush, int ipop)
{
	int i;
	if(ipush == length && ipop == length) 
	{
		for(i = 0; i <= length * 2 - 1; i ++)
		{
			printf("%c ", s2[i]);
		}
		printf("\n");
		return;
	}
	
	if(ipush < length)
	{
		top1 ++;
		top2 ++;
		s1[top1] = a[ipush];
		s2[top2] = 'i';
		dfs(ipush + 1, ipop);
		top1 --;
		top2 --;
	}
	
	if(ipop < ipush && s1[top1] == b[ipop])
	{
		top1 --;
		top2 ++;
		s2[top2] = 'o';
		dfs(ipush, ipop + 1);
		top1 ++;
		s1[top1] = b[ipop];
		top2 --;
	}
	return;
}


int main(void)
{
	while(scanf("%s%s", &a, &b) != EOF)
	{
		length = strlen(a);
		printf("[\n");
		dfs(0, 0);
		printf("]\n");
	}
	return 0;
} 

错误原因:
无。

转载于:https://www.cnblogs.com/moon13579/p/8652692.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值