POJ1797 Heavy Transportation

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 32946 Accepted: 8740
Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5
Sample Output

Scenario #1:
4
题意:一个人带着东西想从a点到b点,要经过的街道有一定的承重力,求所有通路中最大承重力的最大值;跟poj2253差不多,正好与这个题相反http://blog.csdn.net/zxy160/article/details/59623572

#include<stdio.h>
#include<string.h>
#define min(a,b) (a<b?a:b)
#define maxn 2000+10
int d[maxn],map[maxn][maxn];
bool vis[maxn];
int n,m;
void dijkstra(int st,int en)
{
    int i,j,v;
    for(i=1; i<=n; i++)
    {
        vis[i]=0;
        d[i]=map[st][i];//d表示的是i点到起点的最大承载量
    }
    vis[1]=1;
    for(i=1; i<=n-1; i++)
    {
        int maxx=0;
        for(j=1; j<=n; j++)
            if(!vis[j]&&d[j]>maxx)
                maxx=d[j],v=j;//求各个通路中的最大承重力
        if(!maxx)
            break;
        vis[v]=1;
        for(j=1; j<=n; j++)
            if(!vis[j]&&d[j]<min(d[v],map[v][j]))
            {
                d[j]=min(d[v],map[v][j]);//最大承重力中的最大值
            }
    }
    printf("%d\n",d[en]);
}
int main()
{
    int t,casr;
    scanf("%d",&t);
    for(casr=1; casr<=t; casr++)
    {
        scanf("%d%d",&n,&m);
        memset(map,0,sizeof(map));
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            map[x][y]=map[y][x]=z;
        }
        printf("Scenario #%d:\n",casr);
        dijkstra(1,n);
        puts("");
    }
    return 0;
}

复习了一下,理解更清晰了,也找到了错误点

#include<cstdio>
#include<cstring>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a) memset(a,0,sizeof(a))
const int maxn=1005;
int map[maxn][maxn];
int dis[1000005],vis[1000005];
int n,m;
void Dijkstra(int st,int ed)
{
    mem(vis);
    for(int i=1; i<=n; i++)
    {
        dis[i]=map[i][st];
    }
    vis[st]=1;
    for(int i=1; i<m; i++)
    {
        int point=0,maxx=0;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&dis[j]>maxx)
                maxx=dis[j],point=j;
        vis[point]=1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<min(dis[point],map[point][j]))
            {
                //特别注意为什么是小于号
                //dis[j]与(dis[point],map[point][j])是不同的路,或dis[j]根本没有
                //第一种情况:既然是不同的路,当然选择两条路里面最小的路的最大路啦
                 //第二种情况就是不存在那种,那么就是0
                 //同时满足这两个条件就必须小于号
                 //所以也可以改成dis[j]=max(dis[j],min(dis[point],map[point][j]));
                dis[j]=min(dis[point],map[point][j]);
            }
        }
    }
    printf("%d\n",dis[ed]);
}
int main()
{
    int t;
    scanf("%d",&t);
    int k=t;
    while(t--)
    {
        mem(map);
        mem(dis);
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            map[u][v]=map[v][u]=w;
        }
        printf("Scenario #%d:\n",k-t);
        Dijkstra(1,n);
        printf("\n");
    }
    return 0;
}

转载于:https://www.cnblogs.com/zxy160/p/7215156.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值