Heavy Transportation
Time Limit: 3000MS | Memory Limit: 30000K | |
Total Submissions: 16532 | Accepted: 4330 |
Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1 3 3 1 2 3 1 3 4 2 3 5
Sample Output
Scenario #1:
4
/构建一个图,n个顶点和m条边。然后就是每条边都有最大承载量,现在要从1点到n点,求出能运送货物的最大重量。
比如案列所给的1-2-3,其中1-2最大承载量是3, 而2-3最大承载量是5,那么就取决于3,而1-3最大承载量就是4,4>3,故取4……
最大生成树:
代码:
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 1000000001
#define MIN -1000000001
int map[1001][1001];
int dis[1001];
int vis[1001];
int n,m;
void prim(int s){
int k;
memset(vis,0,sizeof(vis));
for(int i=1;i<=n;i++){
dis[i]=map[s][i];
}
dis[s]=0;
vis[s]=1;
int ans=INF;
for(int i=1;i<=n;i++){
int max=MIN;
for(int j=1;j<=n;j++){
if(!vis[j]&&dis[j]>max){
max=dis[j];
k=j;
}
}
ans=min(max,ans);
if(k==n) break;
vis[k]=1;
for(int i=1;i<=n;i++){
if(!vis[i]&&dis[i]<map[k][i]){
dis[i]=map[k][i];
}
}
}
cout<<ans<<endl;
}
int main(){
int t,cas;
int a,b,c;
cin>>t;
for(cas=1;cas<=t;cas++){
cin>>n>>m;
memset(map,-1,sizeof(map));
while(m--){
cin>>a>>b>>c;
map[a][b]=map[b][a]=c;
}
cout<<"Scenario #"<<cas<<":"<<endl;
prim(1);
puts("");
}
return 0;
}