HDU 5067 Harry And Dig Machine(BestCoder Round #14)

Problem Description:
  As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm. 
  Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
 
Input:
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m. (1n,m50).
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0a[i][j]100 , and no more than 10 of a[i][j] will be positive integer).
 
Output:
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
 
Sample Input:
3 3
0 0 0
0 100 0
0 0 0
2 2
1 1
1 1
 
Sample Output:
4
4

题意:给出一个n*m的矩阵,矩阵里面只有少于等于10个的非0值,现在需要将所有的非0值运到左上角((1,1)处),问最少需要多长时间,起点在(1,1)处。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

const int N=1e2+10;
const int INF=0x3f3f3f3f;
const int MOD=1e9+7;

typedef long long LL;

struct node
{
    int x, y;
}no[N];
int a[N][N], n, m, k, ans, vis[N]; ///vis标记点是否被查找过

void DFS(int x, int y, int num, int Time) ///x,y表示当前非0值的位置,num表示已经查找到的非0值,Time表示到达所有非0值需要的时间
{
    int i, T;

    if (Time >= ans) return ; ///如果这次的时间比最小值大,那么回溯,不继续查找(不回溯会超时)

    if (num == k) ///当找到所有非0值时更新最小值
    {
        ans = min(ans, Time+x+y-2); ///此时的x,y是最后一个非0值的位置,那么x+y-2表示从这个位置回到起点的时间
        return ;
    }

    for (i = 0; i < k; i++)
    {
        if (!vis[i])
        {
            vis[i] = 1;
            T = Time + abs(x-no[i].x) + abs(y-no[i].y); ///不能直接用Time,因为下次如果Time不符合会回溯,那么时间会增多
            DFS(no[i].x, no[i].y, num+1, T);
            vis[i] = 0;
        }
    }
}

int main ()
{
    int i, j;

    while (scanf("%d%d", &n, &m) != EOF)
    {
        k = 0;
        ans = INF;
        memset(vis, 0, sizeof(vis));

        for (i = 1; i <= n; i++)
        {
            for (j = 1; j <= m; j++)
            {
                scanf("%d", &a[i][j]);
                
                if (a[i][j]) 
                {
                    no[k].x = i; ///将非0值的位置保存下来
                    no[k++].y = j;
                }
            }
        }

        DFS(1, 1, 0, 0); ///从起点开始搜索

        printf("%d\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/syhandll/p/4932682.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值