hdu5067——Harry And Dig Machine

Harry And Dig Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 497    Accepted Submission(s): 185


Problem Description
  As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm.
  Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
 

Input
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m. (1n,m50) .
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0a[i][j]100 , and no more than 10 of a[i][j] will be positive integer).
 

Output
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
 

Sample Input
  
  
3 3 0 0 0 0 100 0 0 0 0 2 2 1 1 1 1
 

Sample Output
  
  
4 4
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5069  5068  5066  5065  5064


TSP问题,状压DP~~~~

设DP[i | (1 << j)][j] 表示当前走过的城市的状态是 i | (1 << j),当前处在城市j上的最短路径;

则 DP[i | (1 << j)][j] = min(DP [i | (1 << j)][j] , DP[i][k] + dist[k][j])

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <vector>  
#include <queue>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  

using namespace std;

int dp[2050][15];
int dist[15][15];
struct node
{
    int x, y;
}pp[15];

int main()
{
    int n, m;
    while (~scanf("%d%d", &n, &m))
    {
        int cnt = 1;
        int t;
        pp[0].x = 0;
        pp[0].y = 0;
        for (int i = 0; i < n; ++i)
        {
            for (int j = 0; j < m; ++j)
            {
                scanf("%d", &t);
                if (t)
                {
                    pp[cnt].x = i;
                    pp[cnt++].y = j;
                }
            }
        }
        for (int i = 0; i < cnt; ++i)
        {
            for (int j = i; j < cnt; ++j)
            {
                dist[i][j] = abs(pp[i].x - pp[j].x) + abs(pp[i].y - pp[j].y);
                dist[j][i] = dist[i][j];
            }
        }
        memset (dp, 0x3f3f3f3f, sizeof(dp) );
        dp[0][0] = 0;
        for (int i = 0; i < (1 << cnt); ++i)
        {
            for (int j = 0; j < cnt; ++j)
            {
                for (int k = 0; k < cnt; ++k)
                {
                    if(( i & (1 << j) ) == 0)
                    {
                        dp[i | (1 << j)][j] = min(dp[i | ( 1 << j)][j], dp[i][k] + dist[k][j]);
                    }
                }
            }
        }
        printf("%d\n", dp[(1 << cnt) - 1][0]);
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值