PAT 1143-Lowest Common Ancestor (30) 二叉树还原

1143-Lowest Common Ancestor

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 1000), the number of pairs of nodes to be tested; and N (<= 10000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line "LCA of U and V is A." if the LCA is found and A is the key. But if A is one of U and V, print "X is an ancestor of Y." where X is A and Y is the other node. If U or V is not found in the BST, print in a line "ERROR: U is not found." or "ERROR: V is not found." or "ERROR: U and V are not found.".

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意:给出一棵二叉搜索树的先序遍历,询问这个二叉树的LCA。
思路:
其实这个题和LCA的算法关系没有的,就是二叉搜索树的还原加遍历,很简单(⊙﹏⊙),考场上我最后还有十几分钟的时候看到的这个题,看见LCA,心里就已经放弃了。
然后把其他的题的bug补了补,回来后发现这个题真的是冤枉……
按照二叉搜索树的特点直接建树,注意只可以用链式结构存树,会有高度退化的二叉树。
#include "cstdio"
#include "cstring"
using namespace std;

const int maxn = 10000 + 10;

struct node {
    int lson, rson;
    int data;
};

int N, M, res, cnt;
bool vis[maxn];
int pre[maxn];
node trr[maxn];

int build(int L, int R, int root) {
    if (L > R) return -1;
    int r = cnt;
    trr[cnt++].data = pre[root];
    int i = L;
    while (i < M && pre[i] <= pre[root]) i++;
    trr[r].lson = build(L+1, i-1, L+1);
    trr[r].rson = build(i, R, i);
    return r;
}

int travel(int idx, int root) {
    if (root == -1) return -1;
    if (vis[root]) res = trr[root].data;
    vis[root] = true;
    if (idx == trr[root].data) return root;
    if (idx > trr[root].data) return travel(idx, trr[root].rson);
    return travel(idx, trr[root].lson);
}
int main(int argc, char const *argv[])
{
    cnt = 0;
    scanf("%d%d", &N, &M);
    for (int i = 0; i < M; i++) scanf("%d", pre+i);
    build(0, M-1, 0);
    for (int i = 0; i < N; i++) {
        int u, v;
        res = -1;
        memset(vis, false, sizeof(vis));
        scanf("%d%d", &u, &v);
        int a = travel(u, 0);
        int b = travel(v, 0);
        if (a == -1 and b == -1) printf("ERROR: %d and %d are not found.\n", u, v);
        else if (a == -1) printf("ERROR: %d is not found.\n", u);
        else if (b == -1) printf("ERROR: %d is not found.\n", v);
        else if (res == u) printf("%d is an ancestor of %d.\n", u, v);
        else if (res == v) printf("%d is an ancestor of %d.\n", v, u);
        else printf("LCA of %d and %d is %d.\n", u, v, res);
    }
    return 0;
}

转载于:https://www.cnblogs.com/cniwoq/p/8678363.html

以下是C#中二叉树lowest common ancestor的源代码: ```csharp using System; public class Node { public int value; public Node left; public Node right; public Node(int value) { this.value = value; this.left = null; this.right = null; } } public class BinaryTree { public Node root; public BinaryTree() { this.root = null; } public Node LowestCommonAncestor(Node node, int value1, int value2) { if (node == null) { return null; } if (node.value == value1 || node.value == value2) { return node; } Node left = LowestCommonAncestor(node.left, value1, value2); Node right = LowestCommonAncestor(node.right, value1, value2); if (left != null && right != null) { return node; } return (left != null) ? left : right; } } public class Program { public static void Main() { BinaryTree tree = new BinaryTree(); tree.root = new Node(1); tree.root.left = new Node(2); tree.root.right = new Node(3); tree.root.left.left = new Node(4); tree.root.left.right = new Node(5); tree.root.right.left = new Node(6); tree.root.right.right = new Node(7); Node lca = tree.LowestCommonAncestor(tree.root, 4, 5); Console.WriteLine("Lowest Common Ancestor of 4 and 5: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 4, 6); Console.WriteLine("Lowest Common Ancestor of 4 and 6: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 3, 4); Console.WriteLine("Lowest Common Ancestor of 3 and 4: " + lca.value); lca = tree.LowestCommonAncestor(tree.root, 2, 4); Console.WriteLine("Lowest Common Ancestor of 2 and 4: " + lca.value); } } ``` 在上面的代码中,我们定义了一个Node类和一个BinaryTree类。我们使用BinaryTree类来创建二叉树,并实现了一个LowestCommonAncestor方法来计算二叉树中给定两个节点的最近公共祖先。 在LowestCommonAncestor方法中,我们首先检查给定节点是否为null或与给定值之一匹配。如果是,则返回该节点。否则,我们递归地在左子和右子上调用LowestCommonAncestor方法,并检查它们的返回值。如果左子和右子的返回值都不为null,则当前节点是它们的最近公共祖先。否则,我们返回非null的那个子的返回值。 在Main方法中,我们创建了一个二叉树,并测试了LowestCommonAncestor方法的几个不同输入。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值