HDU 2614 Beat【深搜】

Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
Output
For each test case output the maximum number of problem zty can solved.
Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0
Sample Output
3
2
4
题意:
给出N道题目,从0开始做,每做一题之后只能做耗时更多的题目,找出最多能做多少道题目;
分析:采用回溯的方法遍历每一种情况,找出其中做题最多的一个做题路线。
code:
View Code
#include<stdio.h>
#include<string.h>
int p[16][16];
int c[16];
int max;
int n;
void dfs(int row,int now,int tot)
{
int i;
int flag=1;
c[row]=1;
for(i=0;i<n;i++)
if(p[row][i]>=now&&!c[i])
flag=0;
if(flag)
{
if(max<tot)
max=tot;
c[row]=0; //深搜过程中要清除标记!
return;
}
for(i=0;i<n;i++)
if(p[row][i]>=now&&!c[i])
dfs(i,p[row][i],tot+1);
c[row]=0; //深搜过程中清除标记
}
int main()
{
int i,j,tot;
while(scanf("%d",&n)!=EOF)
{
memset(c,0,sizeof(c));
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&p[i][j]);
tot=1;
c[0]=1;
max=0;
for(i=1;i<n;i++)
dfs(i,p[0][i],tot+1);
printf("%d\n",max);
}
return 0;
}

 

转载于:https://www.cnblogs.com/dream-wind/archive/2012/03/15/2397842.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值