Hdu2614Beat

                                         Hdu 2614 Beat(深搜水)

Problem Description

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.

Input

The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.

Output

For each test case output the maximum number of problem zty can solved.

Sample Input

...

Sample output

...

#include <iostream>
#include<map>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<string>
#define ll long long
using namespace std;
const int N=10005;
int n,m,sum;
int maze[N][N],ans,res;
bool vis[N];
int dfs(int x,int condition){
    vis[x]=1;
    for(int i=1;i<=n;i++){
        if(!vis[i]&&maze[x][i]>=condition){
            vis[i]=1;
            res++;
            ans=max(ans,dfs(i,maze[x][i]));
            vis[i]=0;
            res--;
        }
    }
    //cout<<endl;
    vis[x]=0;
    return res;
}
int main()
{
    while(~scanf("%d",&n)){
        ans=res=1;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&maze[i][j]);
            }
            vis[i]=0;
        }
        dfs(1,0);
        cout<<ans<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值