HDU Problem 3665 Seaside【最短路】

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1539    Accepted Submission(s): 1116

Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

 

Sample Input
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

 

Sample Output
2
 

把海边看做是第n个节点,在海边的城镇到海边的距离是0,这样就成了最短路问题的模板问题。

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#define MAXN 1005
using namespace std;
const int INF = 1e9;
int n, m;
bool vis[MAXN], used[MAXN];
int d[MAXN], cost[MAXN][MAXN], pl[MAXN], st[MAXN];
void init() {
    for (int i = 0; i <= n; i++) {
        for (int j = 0; j <= n; j++) {
            if (i == j) cost[i][j] = 0;
            else cost[i][j] = INF;
        }
    }
}
void dijkstra(int x) {
    for (int i = 0; i <= n; i++) {
        d[i] = INF;
    }
    d[x] = 0;
    memset(vis, false, sizeof(vis));
    while (true) {
        int v = -1;
        for (int u = 0; u <= n; u++) {
            if (!vis[u] && (v==-1||d[u]<d[v])) v=u;
        }
        if (v == -1) break; vis[v] = true;
        for (int u = 0; u <= n; u++) {
            d[u] = min(d[u], d[v]+cost[v][u]);
        }
    }
}
int main() {
    int a, b , c, e;
    while (scanf("%d", &n) != EOF) {
        init();
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &a, &b);
            if (b) cost[i][n] = cost[n][i] = 0;
            for (int j = 0; j < a; j++) {
                scanf("%d%d", &c, &e);
                if (cost[i][c] > e)
                cost[i][c] = cost[c][i] = e;
            }
        }
        dijkstra(0);
        printf("%d\n", d[n]);
    }
    return 0;
}

 

 
 

 

转载于:https://www.cnblogs.com/cniwoq/p/6770861.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值