爆炸几何之 CCPC网络赛 I - The Designer (笛卡尔定理)

本文版权归BobHuang和博客园共有,不得转载。如想转载,请联系作者,并注明出处。

 
Nowadays, little  hahahaha got a problem from his teacher.His teacher wants to design a big logo for the campus with some circles tangent with each other. And now, here comes the problem. The teacher want to draw the logo on a big plane. You could see the example of the graph in the Figure1Figure1 



At first, hahahaha's teacher gives him two bigbig circles, which are tangent with each other. And, then, he wants to add more small circles in the area where is outside of the small circle, but on the other hand, inside the bigger one (you may understand this easily if you look carefully at the Figure1Figure1. 

Each small circles are added by the following principles. 
* you should add the small circles in the order like Figure1Figure1. 
* every time you add a small circle, you should make sure that it is tangented with the other circles (2 or 3 circles) like Figure1Figure1. 
     
The teacher wants to know the total amount of pigment he would use when he creates his master piece.hahahaha doesn't know how to answer the question, so he comes to you. 

TaskTask 
The teacher would give you the number of small circles he want to add in the figure. You are supposed to write a program to calculate the total area of all the small circles. 

InputThe first line contains a integer t(1t1200)t(1≤t≤1200), which means the number of the test cases. For each test case, the first line insist of two integers R1R1 and R2R2 separated by a space (1R1001≤R≤100), which are the radius of the two big circles. You could assume that the two circles are internally tangented. The second line have a simple integer NN (1N10 000 0001≤N≤10 000 000), which is the number of small circles the teacher want to add. 
OutputFor each test case: 
Contains a number in a single line, which shows the total area of the small circles. You should out put your answer with exactly 5 digits after the decimal point (NO SPJ). 
Sample Input

2
5 4
1
4 5
1

Sample Output

3.14159
3.14159

这个是题目,很快就看懂了,而且我有了一堆关系可以用,比如第几个圆,还有些相切的关系

但这个题我肯定是要用题解方法做的,不然精度炸飞

援引自百度百科,百度百科来源于一篇论文(见《笛卡尔定理与一类多圆相切问题》(作者:王永喜、李奋平)。)

若平面上四个半径为r 1、r 2、r 3、r 4的圆两两相切于不同点,则其半径满足以下结论:
(1)若四圆两两外切,则
   
(2)若半径为r 1、r 2、r 3的圆内切于半径为r 4的圆中,则
   
笛卡尔定理在 三维坐标系中也有类似的结论:若五个球的半径是r i(1,2,...,5),满足任意一个球与其他四个球外切,则
   

这个为什么是成立的呢

可以从最简单的推

设三个圆的半径分别是a,b,c

然后就

 

这道题和论文中的这个内容相似

 

把1替换成r,2替换成R就可以对这个图进行求解

有个专业术语叫Pappus chain

 

有些美妙吧

 

#include<bits/stdc++.h>
using namespace std;
const double eps=1e-13;
const double PI=acos(-1.0);
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int R,r,n;
        scanf("%d%d%d",&R,&r,&n);
        if(R<r)swap(R,r);
        double k1=-1.0/R,k2=1.0/r,k3=1.0/(R-r);
        double k4=k1+k2+k3;
        double ans=(R-r)*(R-r);
        n--;
        double t=1./k4/k4;
        for(int i=1; i<=n&&t>eps; i+=2)
        {
            ans+=t;
            if(i+1<=n)ans+=t;
            double k5=2*(k1+k2+k4)-k3;
            k3=k4;
            k4=k5;
            t=1./k4/k4;
        }
        printf("%.5f\n",ans*PI);
    }
    return 0;
}

本文版权归BobHuang和博客园共有,不得转载。如想转载,请联系作者,并注明出处。

 

转载于:https://www.cnblogs.com/BobHuang/p/7402967.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值