poj2075

Tangled in Cables
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6348 Accepted: 2505

Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought. Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.
  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house's owner. Each name consists of up to 20 characters {a–z,A–Z,0–9} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >
Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output
Not enough cable
If there is enough cable, then output
Need < X > miles of cable
Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable

Source

POJ2075 Tangled in Cables 最小生成树
题目大意:

给你一些人名,然后给你n条连接这些人名所拥有的房子的路,求用最小的代价求连接这些房子的花费是否满足要求。

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
#define N 15010
map<string,int>ad;
struct node{
    int x,y;
    double v;
    node(int x=0,int y=0,double v=0):x(x),y(y),v(v){}
}e[N];
int n,m,fa[N];double money;
int find(int x){
    return fa[x]==x?x:fa[x]=find(fa[x]);
}
bool cmp(const node &a,const node &b){
    return a.v<b.v;
}
int main(){
    freopen("sh.in","r",stdin);
    scanf("%lf%d",&money,&n);
    for(int i=1;i<=n;i++){
        char str[60];
        scanf("%s",str);
        ad[str]=i;
    }
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        char c1[60],c2[60];
        double cost;
        scanf("%s %s %lf",c1,c2,&cost);
        e[i].x=ad[c1];
        e[i].y=ad[c2];
        e[i].v=cost;
    }
    sort(e+1,e+m+1,cmp);
    double ans=0;int k=0;
    for(int i=1;i<=n;i++) fa[i]=i;
    for(int i=1;i<=m;i++){
        int fx=find(e[i].x),fy=find(e[i].y);
        if(fx!=fy){
            fa[fy]=fx;
            ans+=e[i].v;
            k++;
        }
        if(k==n-1) break;
    }
    if(money>ans) printf("Need %.1lf miles of cable\n",ans);
    else printf("Not enough cable\n");
    return 0;
}

 

转载于:https://www.cnblogs.com/shenben/p/5630189.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值