Num 36 : ZOJ 2100 [ 深度优先搜索算法 ] [ 回溯 ]



        该题是用回溯法来解决的题:


题目:

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field,which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO


         题目大意:

             从左上角開始行进,能不能不走回头路的把地图上全部点走一遍;( S代表障碍物 )。


         题目分析:

             从左上角開始,利用回溯法进行深搜。推断有没有一种情况。能不回头的把一条路走完;


AC代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int x,y,m,n,snum,max=0,flag;
char map[10][10];
void fun(int x,int y)
{
	if(x<1||x>m||y<1||y>n) return;
    if(map[x][y]=='S') return;
    if(flag==1) return;
	map[x][y]='S';
	snum++;
	if(snum==m*n)
    {
    	flag=1;
    	return;
    }
	fun(x-1,y);
	fun(x+1,y);
	fun(x,y-1);
	fun(x,y+1);
	snum--;
	map[x][y]='.';
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),m|n)
	{
		snum=0;
		for(i=1;	i<=m;	i++)
			for(j=1;	j<=n;	j++)
			{
				scanf(" %c",&map[i][j]);
				if(map[i][j]=='S') snum++;
			}
		flag=0;
		fun(1,1);
		if(flag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值