山东理工OJ【2054】双向链表(两种方法)



双向链表

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

学会了单向链表,我们又多了一种解决问题的能力,单链表利用一个指针就能在内存中找到下一个位置,这是一个不会轻易断裂的链。但单链表有一个弱点——不能回指。比如在链表中有两个节点A,B,他们的关系是BA的后继,A指向了B,便能轻易经A找到B,但从B却不能找到A。一个简单的想法便能轻易解决这个问题——建立双向链表。在双向链表中,A有一个指针指向了节点B,同时,B又有一个指向A的指针。这样不仅能从链表头节点的位置遍历整个链表所有节点,也能从链表尾节点开始遍历所有节点。对于给定的一列数据,按照给定的顺序建立双向链表,按照关键字找到相应节点,输出此节点的前驱节点关键字及后继节点关键字。

输入

第一行两个正整数n(代表节点个数),m(代表要找的关键字的个数)。接下来n行每行有一个整数为关键字key(数据保证关键字在数列中没有重复)。接下来有m个关键字,每个占一行。

输出

对给定的每个关键字,输出此关键字前驱节点关键字和后继节点关键字。如果给定的关键字没有前驱或者后继,则不输出。给定关键字为每个输出占一行。

 

示例输入

10 3
1 2 3 4 5 6 7 8 9 0
3
5
0

示例输出

2 4
4 6
9
 
  
 
  
 
  
 
  
 
  
(一)单链表法


#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct node *next;

} ;//定义链表的节点

struct node *creat(int n)

{

    int i;

    struct node *head,*p,*tail;

    head=(struct node *)malloc(sizeof(struct node));

    head->next=NULL;

    tail=head;

    for(i=0; i<n; i++)

    {

        p=(struct node *)malloc(sizeof(struct node));

        scanf("%d",&p->data);

        p->next=NULL;

        tail->next=p;

        tail=p;

    }

    return head;

};//顺序建立链表

struct node *found(struct node *head,int key)//查找函数

{

    struct node *p,*q;

    p=head->next;

    q=head;

    while(p->next!=NULL)

    {

        if(p->data==key)

        {

            if(q==head)

                printf("%d\n",p->next->data);

            else

                printf("%d %d\n",q->data,p->next->data);

            break;

        }

        q=p;

        p=p->next; 

    }

    if(p->next==NULL)

        printf("%d\n",q->data);

        return NULL;

};

int main()

{

    int key,n,m,i;

    struct node *head;

    scanf("%d %d",&n,&m);

    head=creat(n);

    for(i=0; i<m; i++)

    {

        scanf("%d",&key);

        found(head,key);

    }

    return 0;

}



 
  

 

(二)双向链表法

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *last;//保存前一个节点的地址
    struct node *next;
};
struct node *creat(int n)//建立双向链表
{
    int i;
    struct node *head,*p,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    head->last=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        p->last=tail;
        tail->next=p;
        tail=p;
    }
    return head;
};
void ser(struct node *head)
{
    int key;
    struct node *p;
    scanf("%d",&key);
    p=head->next;
    while(p!=NULL)
    {
        if(p->data==key)
        {
            if(p->next!=NULL&&p->last==head)
            {
                printf("%d\n",p->next->data);
                break;
            }


            else if(p->next!=NULL&&p->last!=head)
            {
                printf("%d %d\n",p->last->data,p->next->data);
                break;
            }
            else
            {
                printf("%d\n",p->last->data);
                break;
            }
        }
            p=p->next;
    }
}
int main()
{
    int n,m,i;
    struct node *head;
    scanf("%d %d",&n,&m);
    head=creat(n);
    for(i=0;i<m;i++)
        ser(head);
    return 0;
}



转载于:https://www.cnblogs.com/jiangyongy/p/3971706.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值