HDU 2162(注意初始化位置!)

Add ‘em

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4144    Accepted Submission(s): 2976


Problem Description
Write a program to determine the summation of several sets of integers.
 

 

Input
The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.
 
Output
A single line of output should be generated for each set of integers. The line should have format shown below.
 

 

Sample Input
4 -1 3 1 1 2 19 17 5 -645 952 -1488 -5456 -9342 -1
 

 

Sample Output
Sum of #1 is 4 Sum of #2 is 36 Sum of #3 is -15979
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int t,a,sum,c=1;
    while(~scanf("%d",&t))
    {
        if(t<=0)
            break;
        sum=0;
        //c=1;//注意位置,不是这里初始化!
        while(t--)
        {
            scanf("%d",&a);
            sum+=a;
        }
        printf("Sum of #%d is %d\n",c++,sum);
    }
    return 0;
}

  

 

转载于:https://www.cnblogs.com/Roni-i/p/7220302.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值