Codeforces Gym 100418A A - A+-B java高精度

A - A+-B
Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=86686#problem/A

Description

You are given the integer numbers A and B. Output A + B or A - B.

Input

The first line contains two numbers AB separeted by a single space ( - 263 ≤ A, B < 263).

Output

Output one integer number: A + B or A - B.

Sample Input

15 27

Sample Output

42

HINT

 

题意

给你a,b,让你输出a+b或者a-b,需要保证输出的值是一个integer

题解

高精度一下,然后输出最小的就好了

用的JAVA = =

代码:

import java.util.*;   
import java.io.*;   
import java.math.*;     
public class Main  
{  
    public static void main(String [] args)  
    {  
        Scanner in = new Scanner(System.in);  
        BigInteger a = in.nextBigInteger();  
        BigInteger b = in.nextBigInteger();  
        BigInteger c = a.add(b);
        BigInteger d = a.subtract(b);
        BigInteger f;
        BigInteger kiss;
        kiss = BigInteger.valueOf(0);
        f = BigInteger.valueOf(-1);
        int test = d.compareTo(kiss);
        if( test == -1 )
            d = d.multiply(f);
        test = c.compareTo(d);
        if( test == 1 )
            System.out.println(a.subtract(b));
        else
            System.out.println(a.add(b));
    }  
}  

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值