POJ 1463 Strategic game

Strategic game
Time Limit: 2000MS Memory Limit: 10000K

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier ( at the node 1).
Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.
Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:
Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output

1
2

思路:
① 树形DP
f[x][0]表示不在这个点放。 f[x][1]表示 在这个点放。
f[father][0]+=f[son][1];
f[father][1]+=min(f[son][1],f[son][0]);
② 二分图最小覆盖

树形DP:

//By: Sirius_Ren
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n,jyx,jyy,jy,next[3001],first[3001],v[3001],tot=0,f[3001][2];
void add(int x,int y){v[tot]=y;next[tot]=first[x];first[x]=tot++;}
void dfs(int x,int fa){
    for(int i=first[x];~i;i=next[i]){
        if(v[i]==fa)continue;
        dfs(v[i],x);
        f[x][0]+=f[v[i]][1];
        f[x][1]+=min(f[v[i]][1],f[v[i]][0]);
    }
}
int main()
{
    while(~scanf("%d",&n)){
        memset(first,-1,sizeof(first)),tot=0;
        for(int i=1;i<=n;i++){
            scanf("%d:(%d)",&jyx,&jyy);
            while(jyy--)scanf("%d",&jy),add(jyx,jy),add(jy,jyx);
        }
        for(int i=0;i<=n;i++)f[i][1]=1,f[i][0]=0;
        dfs(0,1501);
        printf("%d\n",min(f[0][1],f[0][0]));
    }
}

二分图最小覆盖:

//By: Sirius_Ren
#include <cstdio>
#include <cstring>
using namespace std;
int n,jyx,jyy,jy,next[3001],first[3001],v[3001],tot=0,vis[1501],ans,fa[1501];
void add(int x,int y){v[tot]=y;next[tot]=first[x];first[x]=tot++;}
bool dfs(int x){
    for(int i=first[x];~i;i=next[i])
        if(!vis[v[i]]){
            vis[v[i]]=1;
            if(!fa[v[i]]||dfs(fa[v[i]])){fa[v[i]]=x;return 1;}
        }
    return 0;
}
int main()
{
    while(~scanf("%d",&n)){
        memset(fa,0,sizeof(fa));
        memset(first,-1,sizeof(first)),tot=ans=0;
        for(int i=1;i<=n;i++){
            scanf("%d:(%d)",&jyx,&jyy);
            while(jyy--)scanf("%d",&jy),add(jyx,jy),add(jy,jyx);
        }
        for(int i=0;i<n;i++){
            memset(vis,0,sizeof(vis));
            if(dfs(i))ans++;
        }
        printf("%d\n",ans/2);
    }
}

这里写图片描述

转载于:https://www.cnblogs.com/SiriusRen/p/6532439.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值