POJ-1463 Strategic game (最小点覆盖+树形DP+处理点)

Strategic game

Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 9324 Accepted: 4372

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  •  
  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

Southeastern Europe 2000

 

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
#define MAXN 2000
vector <int> G[MAXN];
int dp[MAXN][MAXN];   //dp[i][1]表示取i结点时,以i为根的子树能取的最小值
                      //dp[i][0]表示不取i结点时,以i为根的子树能取的最小值
                      //树形DP状态转移从叶子结点开始向根不断转移,所以用深搜。
                      //搜到叶子结点就结束。
                      //转移的时候可以将结点以下给圈起来。
                      //取与不取,树上背包
void dfs(int u)
{
    int i;
    if(G[u].size()==0)
    return;
    for(i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        dfs(v);
        dp[u][1]+=min(dp[v][0],dp[v][1]);
        dp[u][0]+=dp[v][1];
    }
}
int main()
{
    int n;
    int i,j,k;
    int u,v;
    int temp[MAXN];
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)   //结点的下标一定是0~n-1
        {
            scanf("%d:(%d)",&u,&k);
            temp[i]=u;
            for(j=1;j<=k;j++)
            {
                scanf("%d",&v);
                G[u].push_back(v);
            }
        }
        for(i=0;i<n;i++)        //dp[i][0]的i从0开始,因为存在下标为0的结点
        {                       //再次强调结点的下标一定是0~n-1
            dp[i][1]=1;
            dp[i][0]=0;
        }
        dfs(temp[0]);           //这个一定是从最开始的结点开始的
        printf("%d\n",min(dp[temp[0]][1],dp[temp[0]][0]));
        for(i=0;i<n;i++)        //vector的清空。
        {
            G[i].clear();
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值