HDU Problem 5636 Shortest Path 【Floyd】

 

Shortest Path

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1587    Accepted Submission(s): 513

Problem Description
There is a path graph  G=(V,E) with  n vertices. Vertices are numbered from  1 to  n and there is an edge with unit length between  i and  i+1  (1i<n). To make the graph more interesting, someone adds three more edges to the graph. The length of each new edge is  1.

You are given the graph and several queries about the shortest path between some pairs of vertices.
 

 

Input
There are multiple test cases. The first line of input contains an integer  T, indicating the number of test cases. For each test case:

The first line contains two integer  n and  m  (1n,m105) -- the number of vertices and the number of queries. The next line contains 6 integers  a1,b1,a2,b2,a3,b3  (1a1,a2,a3,b1,b2,b3n), separated by a space, denoting the new added three edges are  (a1,b1)(a2,b2)(a3,b3).

In the next  m lines, each contains two integers  si and  ti  (1si,tin), denoting a query.

The sum of values of  m in all test cases doesn't exceed  106.
 

 

Output
For each test cases, output an integer  S=(i=1mizi) mod (109+7), where  zi is the answer for  i-th query.
 

 

Sample Input
1 10 2 2 4 5 7 8 10 1 5 3 1
 

 

Sample Output
7
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 
 

题意:有一个节点数为n的链表,每个节点相距一个单位的长度,但是有三个传送门,问你每次给出两点的最短距离是多少

 

思路:如果没有传送门的存在,距离是abs(x - y),但是现在多了传送门,总共也就6个,可以预处理每个传送门的距离,两次for循环,试一下每次从传送门a进入,再从任意一个出去的距离。

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
#define space " "
using namespace std;
//typedef long long LL;
typedef __int64 Int;
typedef pair<int,int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double Pi = acos(-1);
const int MOD = 1e9 + 7;
const int MAXN = 1e5 + 10;
Int d[7][7], a[7];
Int abs_long(Int x) {
    if (x < 0) return -x;
    return x;
}
int main() {
    int t, m, n;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &m);
        for (int i = 0; i < 3; i++) {
            scanf("%I64d%I64d", &a[i], &a[i + 3]);
        }
        //初始化传送门之间的距离
        for (int i = 0; i < 6; i++) {
            for (int j = 0; j < 6; j++) {
                d[i][j] = abs_long(a[i] - a[j]);
            }
        }
        for (int i = 0; i < 3; i++) {
            d[i][i + 3] = d[i + 3][i] = 1;
        }
        for (int k = 0; k < 6; k++) {
            for (int i = 0; i < 6; i++) {
                for (int j = 0; j < 6; j++) {
                    d[i][j] = min(d[i][j], d[i][k] + d[k][j]);
                }
            }
        }
        Int x, y; Int ans = 0, temp, sum;
        for (int  k = 1; k <= m; k++) {
            scanf("%I64d%I64d", &x, &y);
            temp = abs_long(x - y);
            //用每一个传送门检查最短距离
            for (int i = 0; i < 6; i++) {
                for (int j = 0; j < 6; j++) {
                    sum = abs_long(x - a[i]) + d[i][j] + abs_long(y - a[j]);
                    temp = min(sum, temp);
                }
            }
            ans = (ans + temp*k)%MOD;
        }
        printf("%I64d\n", ans);
    }
    return 0;
}

 

 





 

转载于:https://www.cnblogs.com/cniwoq/p/6770803.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值