HDU_1227_Fast Food_动态规划

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1227

Fast Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2695    Accepted Submission(s): 1142


Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots. 

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built. 

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized. 
 

 

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed. 
 

 

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum. 

Output a blank line after each test case.
 

 

Sample Input
6 3 5 6 12 19 20 27 0 0
 

 

Sample Output
Chain 1 Total distance sum = 8
 
一来没思路,看了题解,目前动态规划的题几乎都看了题解才有思路。。。。。。
思路:[i,j]之间加一个仓库,为了使要增加的路程最短,只能加在第(int)(i+j)/2个餐厅。
case[i][j]为在[i,j]之间加一个仓库所要增加的路程。
dp[i][j]表示在前j个餐厅之中加i个仓库所要走的路程。
状态转移方程:dp[i][j]=min(dp[i][j],dp[i-1][m]+case[m+1][j]);  (i-1<=m<=j-1)
 
#include<iostream>
#include<cstdio>
#include<stdlib.h>
#include<cstring>
using namespace std;
#define LL long long

int dis[205];
int dist[205][205];
int dp[35][205];

int main()
{
    int n,k,cases=1;
    while(scanf("%d%d",&n,&k)!=EOF&&n&&k)
    {
        memset(dist,0,sizeof(dist));

        for(int i=0; i<=k; i++)
            for(int j=0; j<=n; j++)
                dp[i][j]=2000000000;
                //cout<<dp[0][0];
        dp[0][0]=0;
        dp[1][1]=0;
        for(int i=1; i<=n; i++)
            scanf("%d",&dis[i]);
        for(int i=1; i<=n-1; i++)
            for(int j=i; j<=n; j++)
            {
                int mid=(i+j)/2;
                for(int k=i; k<=j; k++)
                    dist[i][j]+=abs(dis[mid]-dis[k]);
            }
        for(int i=1;i<=n;i++)
            dp[1][i]=dist[1][i];
        for(int j=2; j<=n; j++)
            for(int i=2; i<=j,i<=k; i++)
                for(int m=i-1; m<=j-1; m++)
                    dp[i][j]=min(dp[i][j],dp[i-1][m]+dist[m+1][j]);

        printf("Chain %d\n",cases++);
        printf("Total distance sum = %d\n\n",dp[k][n]);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/jasonlixuetao/p/5468589.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值