十、EIGRP实验
实验目的:1、学习EIGRP路由协议的配置。
               2、学习EIGRP路由协议对连续网络无类路由的支持。
               希望大家能仔细研究一下下面ip地址中子网的划分(参考第七篇)。
实验拓扑
1、ip地址表:
PC1            IP                     192.168.10.18/28          DG       192.168.10.17
PC2            IP                     192.168.10.34/27          DG       192.168.10.33
R1              F0/0                 192.168.10.17/28
R1              S2/0                  192.168.10.5/30
R2              S2/0                  192.168.10.6/30
R2              S3/0                  192.168.10.9/30
R3              S2/0                  192.168.10.10/30
R3              F0/0                 192.168.10.33/27
2、
R1的配置:
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.17 255.255.255.240
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 192.168.10.5 255.255.255.252
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to down
R1(config-if)#exit
R1(config)#router eigrp 10 //启用eigrp路由协议,自治系统号为10;路由的自治号相同才可通信
R1(config-router)#network 192.168.10.0 //通告直连网络
 
R2的配置:
R2(config)#interface serial 2/0
R2(config-if)#ip address 192.168.10.6 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#exit
R2(config)#interface serial 3/0
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial3/0, changed state to down
R2(config-if)#exit
R2(config)#router eigrp 10
R2(config-router)#network 192.168.10.0
 
R3的配置:
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.10.33 255.255.255.224
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#interface serial 2/0
R2(config-if)#ip address 192.168.10.10 255.255.255.252
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
R2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#exit
R2(config)#router eigrp 10
R2(config-router)#network 192.168.10.0
 
验证:PC1  ping  PC2             
PC>ping 192.168.10.34
Pinging 192.168.10.34 with 32 bytes of data:
Request timed out.
Reply from 192.168.10.34: bytes=32 time=168ms TTL=125
Reply from 192.168.10.34: bytes=32 time=157ms TTL=125
Reply from 192.168.10.34: bytes=32 time=167ms TTL=125
 
结论:
1、可见eigrp路由协议配置成功;
2、在连续网络的无类路由中,eigrp可以学习到所有子网路由信息。