最长上升子序列输出下标

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8025    Accepted Submission(s): 3556
Special Judge

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 

Sample Output
4
4
5
9
7

  

//FatMouse's Speed1160
//#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#define MAX 1001
using namespace std;
struct Mouse{ int w, s, id; };
Mouse m[MAX];
int dp[MAX], id[MAX];
bool cmp(Mouse a, Mouse b){
    if (a.s != b.s){
        return a.s > b.s;
    }
    return a.w < b.w;
}
void out(int i){//递归输出下标,,,,太感动了,就是这里纠结了n个小时

    if (i== 0)return;
    else out(id[i]);
    cout << m[i].id << endl;
}
int main()
{
    int i, n, j, totle, w, s, pos=0;
    i = 0;
    while (cin >> w >> s){
        ++i;
        m[i].w = w;
        m[i].s = s;
        m[i].id = i;
    }
    sort(m+1, m + i+1, cmp);
    n = i;//老鼠个数
    memset(id, 0, sizeof(id));
    totle = 0;
    for (i = 1; i <= n; i++){
        dp[i] = 1;
        for (j = 1; j < i; j++){
            if (m[j].w<m[i].w && m[j].s>m[i].s){
                if (dp[i]<dp[j]+1){
                    dp[i] = dp[j]+1;
                    id[i] = j;
                }
            }
        }
        if (dp[i]>totle){
            totle = dp[i];
            pos = i;
        }
        //totle = max(totle, dp[i]);
    }

    cout << totle << endl;
    out(pos);

    system("pause");
    return 0;
}

 

转载于:https://www.cnblogs.com/littlehoom/p/3552969.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值