OSPF 不规则区域小实验

R6:
interface FastEthernet0/0
 ip address 192.168.1.6 255.255.255.0
 duplex auto
 speed auto
!        
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router rip
 version 2
 network 192.168.1.0
 no auto-summary
!        

 

 

 


R1:
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 172.16.1.1 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 100
 log-adjacency-changes
 area 1 nssa default-information-originate
 redistribute rip subnets
 network 172.16.1.1 0.0.0.0 area 1
!        
router rip
 version 2
 redistribute ospf 100 metric 1
 network 192.168.1.0
 no auto-summary
!        

 

 

 

R2:
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 172.16.1.2 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 ip address 10.1.1.2 255.255.255.0
 clock rate 2000000
!        
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 area 1 nssa no-redistribution default-information-originate
 area 1 nssa translate type7 suppress-fa
 network 10.1.1.2 0.0.0.0 area 0
 network 172.16.1.2 0.0.0.0 area 1
!        

 

 

 

R3:
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 10.1.1.3 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 ip address 11.1.1.3 255.255.255.0
 clock rate 2000000
!        
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.1.1.3 0.0.0.0 area 0
 network 11.1.1.3 0.0.0.0 area 2

 

 

 

R4:
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 11.1.1.4 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 ip address 14.1.1.4 255.255.255.0
 clock rate 2000000
!        
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 redistribute rip subnets
 network 11.1.1.4 0.0.0.0 area 2
!        
router rip
 version 2
 redistribute ospf 100 metric 1
 network 14.0.0.0
 no auto-summary
!        

 

 

 

R5:
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 14.1.1.5 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router rip
 version 2
 network 14.0.0.0
 no auto-summary
!