p_w_picpath

R1和R2之间运行RIP,R2和R3之间运行BGP,R3和R4之间运行OSPF

目标:R1和R4可以互相PING通

 

配置:

R1:

ipv6 unicast-routing

!

interface Loopback0
no ip address
ipv6 address 1::1/128
ipv6 rip cisco enable
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:12::1/64
ipv6 rip cisco enable
!
ipv6 router rip cisco

 

R2:

ipv6 unicast-routing
!        
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:12::2/64
ipv6 rip cisco enable
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 2001:23::2/64
!
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 2001:23::3 remote-as 1
!
address-family ipv6
  neighbor 2001:23::3 activate                     //激活IPv6
  bgp redistribute-internal                           //允许从IBGP学到的路由重分发进IGP
  redistribute rip cisco include-connected   //重分发时包括直连,默认IPv6重分发不带直连
  no synchronization
exit-address-family
!
ipv6 router ospf 1
log-adjacency-changes
!
ipv6 router rip cisco
redistribute bgp 1 include-connected                       

 

 

R3:

ipv6 unicast-routing
!        
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:23::3/64
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 2001:34::3/64
ipv6 ospf 1 area 0
!
router bgp 1
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 2001:23::2 remote-as 1
no auto-summary
!
address-family ipv6
  neighbor 2001:23::2 activate
  bgp redistribute-internal
  redistribute ospf 1 include-connected
  no synchronization
exit-address-family
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute bgp 1 include-connected

 

R4:

ipv6 unicast-routing
!        
interface Loopback0
no ip address
ipv6 address 4::4/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:34::4/64
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 4.4.4.4
log-adjacency-changes

 

 

 

 

 

 

R1 PING R4