poj 1552 Doubles(简单的模拟一下)

Doubles
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16425 Accepted: 9404

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

Source

分析:

(1)题意:求每行中有二倍关系的数字的组数。

(2)模拟,因为每行最多不超过14个数字,数字的范围是99以内所以开辟一个100大小的数组,使用标记位的方法标记这个数字是否存在,这样判断二倍关系是就方便了许多

#include <stdio.h>

int main()
{
    int i,num[100],index,count;
    while(1)
    {
        //将数组初始化-1
        for(i=0;i<100;i++)num[i] = -1;
        count = 0;
        scanf("%d",&index);
        if(index==-1)break;
        while(1)
        {
            num[index]=1;
            scanf("%d",&index);
            if(index==0)break;
        }
        for(i=0;i<100;i++)
        if(i*2<100&&num[i]==1&&num[i*2]==1)
        count++;
        printf("%d\n",count);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值