HDU 4764:Stone(巴什博弈)

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2204    Accepted Submission(s): 1553


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.  

Sample Input
 
  
1 1
30 3
10 2
0 0  

Sample Output
 
  
Jiang
Tang
Jiang


题意:Tang和Jiang两个人写数字,Tang先写,每次前一个人和后一个人写的数字分别为x,y;满足:1<=y-x<=k。在第一轮中,Tang写的数字在1~k之间,谁写的数字不小于n就输了。

思路:可以看做是每轮n变成n-x-y,问最后一轮n是否等于1 。如果等于1的话则Jiang获胜。

          可以转化为巴什博弈问题:有n-1个石子,每次至少取1个,最多取k个,问谁能拿到最后一个石子

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
using namespace std;
const int maxn=1e6+10;
int main()
{
	int n,k;
	while(cin>>n>>k&&n&&k)
	{
		if((n-1)%(k+1)==0)
			cout<<"Jiang"<<endl;
		else
			cout<<"Tang"<<endl;
	}
	return 0;
}

转载于:https://www.cnblogs.com/Friends-A/p/9309000.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值