(HDU - 4764) Stone(巴什博弈)

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students. 

Input     There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero. 

Output   For each case, print the winner's name in a single line. 

Sample Input
1 1
30 3
10 2
0 0
Sample Output
Jiang
Tang
Jiang

       

题目大意T和J轮流写数,T先写一个[1,k]之间的数x,然后J再写一个比x大[1,k]的数y,然后再轮到T写比y大[1,k]的数x,再轮到J....,每次写的数都比上一个人写的数大[1,k],直到某个人写的数大于等于n,这个人就输了

题目分析:这是一道巴什博弈的应用,当写到n-1时,下一个写数的人必败。如果n-1=k+1,则先手必败,由此得出如果(n-1)%(k+1)=0,则先手必败,否则先手必胜。

代码如下:

#include <iostream>

using namespace std;
int main()
{
    int n,k;
    while(cin>>n>>k&&n&&k)
    {
        if((n-1)%(k+1)==0)
            cout<<"Jiang"<<endl;
        else
            cout<<"Tang"<<endl;
    }
    return 0;

}

巴士博弈参考博客:https://blog.csdn.net/ac_gibson/article/details/41624623

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值