POJ 2251 Dungeon Master【三维BFS模板】

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45743 Accepted: 17256
Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
Source

Ulm Local 1997

【代码】:

#include<cstdio>
#include<string>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<cstring>
#include<set>
#include<queue>
#include<algorithm>
#include<vector>
#include<map>
#include<cctype>
#include<stack>
#include<sstream>
#include<list>
#include<assert.h>
#include<bitset>
#include<numeric>
using namespace std;

typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int,int> P;
const int INF = 0x3f3f3f3f;
const LL LNF = 1e18;
const int maxn = 1e6;
const int maxm = 100;
const double PI = acos(-1.0);
const double eps = 1e-8;
const int dx[] = {-1,1,0,0,1,1,-1,-1};
const int dy[] = {0,0,1,-1,1,-1,1,-1};
const int mon[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
const int monn[] = {0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};

const int dir[6][3]={ {0,0,1},{0,0,-1},{-1,0,0},{1,0,0},{0,1,0},{0,-1,0} };
struct node
{
    int x;
    int y;
    int z;
    int step;
}st,ed;
char maze[50][50][50]; //迷宫
int vis[50][50][50];   //表示是否访问过
int l,r,c; //l表示层数 r表示行数 c表示列数
int sx,sy,sz;  //起点坐标
int ex,ey,ez;

int check(int z,int x,int y) //判断该点是否可以走
{
    if(x>=0&&x<r&&y>=0&&y<c&&z>=0&&z<l&&maze[z][x][y]!='#')
        return 1;
    else
        return 0;
}

void bfs()
{
    memset(vis,0,sizeof(vis));
    queue <node> q;
    //把起点放入队列,并且标记
    //node st,ed;
    st.x = sx;
    st.y = sy;
    st.z = sz;
    st.step = 0;
    vis[st.z][st.x][st.y]=1;
    q.push(st);
    //不断循环知道队列的长度为0
    while(!q.empty())
    {
        //从队列的最前端取除元素看是否有路可通,如果没有路则返回这个点
        st = q.front();
        q.pop();
        //如果取出来是终点,则证明逃出地牢 搜索结束
        if(maze[st.z][st.x][st.y]=='E')
        {
            printf("Escaped in %d minute(s).\n",st.step);
            return;
        }
        //六个方向遍历
        for(int i = 0 ; i < 6 ;i++)
        {
            ed.z = st.z + dir[i][0];
            ed.x = st.x + dir[i][1];
            ed.y = st.y + dir[i][2];
            ed.step = st.step+1;
            if(check(ed.z,ed.x,ed.y)==0) //如果此方向不通就继续判断其他方向
                continue;
            if(vis[ed.z][ed.x][ed.y]==0)
            {
                vis[ed.z][ed.x][ed.y] = 1;
                q.push(ed);
            }
        }
    }
    printf("Trapped!\n");
}

int main()
{
    while(scanf("%d%d%d",&l,&r,&c)&&l&&r&&c)
    {
        for(int i = 0; i < l; i++)//输入各个点的坐标
        {
            for(int j = 0; j < r; j++)
            {
                scanf("%s",maze[i][j]);
                for(int k = 0; k < c ; k++)
                {
                    if(maze[i][j][k]=='S')
                    {
                        sz = i;
                        sx = j;
                        sy = k;
                    }

                }
            }
        }

        bfs();
    }
}

转载于:https://www.cnblogs.com/Roni-i/p/9192579.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ2251是一个经典的题目,也被称为"水仙花的谜题"。该题目要求在一个三维的迷宫中找到从起点到终点的最短路径。 在这个题目中,迷宫由一个3D的数组表示,每个位置上的值代表了该位置的状态。其中,0表示可以通过的路径,1表示墙壁,2表示起点,3表示终点。你需要编写一个程序来找到从起点到终点的最短路径,并输出路径的长度。 解决这个问题的一种常见方法是使用广度优先搜索(BFS)算法。BFS算法可以从起点开始,逐层遍历迷宫中的位置,直到找到终点或者遍历完所有可达位置。在遍历过程中,你需要记录每个位置的距离和路径信息,以便找到最短路径。 以下是解决该问题的大致思路: 1. 定义一个队列,将起点加入队列,并标记起点已访问。 2. 使用循环来遍历队列中的元素,直到队列为空。 3. 在循环中,取出队列中的元素,并获取其相邻可达位置。 4. 对于每个相邻位置,判断是否为终点,如果是则输出最短路径长度并结束程序。 5. 如果不是终点,则判断该位置是否为可通过的路径,并且未被访问过。如果满足条件,则将该位置加入队列,并更新距离和路径信息。 6. 重复步骤2-5,直到找到终点或者遍历完所有可达位置。 这只是一个简单的介绍,实际解决该问题还需要考虑一些细节,比如如何表示迷宫、如何判断位置的合法性等。你可以在编写代码时参考相关的算法和数据结构知识。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值