HDU5480:Conturbatio(前缀和)

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1035    Accepted Submission(s): 472


Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

Input
The first line of the input is a integer  T, meaning that there are  T test cases.

Every test cases begin with four integers  n,m,K,Q.
K is the number of Rook,  Q is the number of queries.

Then  K lines follow, each contain two integers  x,y describing the coordinate of Rook.

Then  Q lines follow, each contain four integers  x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000.

1xn,1ym.

1x1x2n,1y1y2m.
 

Output
For every query output "Yes" or "No" as mentioned above.
 

Sample Input
 
  
2 2 2 1 2 1 1 1 1 1 2 2 1 2 2 2 2 2 1 1 1 1 2 2 1 2 2
 

Sample Output
 
  
Yes No Yes
Hint
Huge input, scanf recommended.
 

Source

详情请参考:http://blog.csdn.net/loiecarsers/article/details/48862755

# include <stdio.h>
# include <string.h>
# define MAXN 100000
int main()
{
    int cx, cy, x1, x2, y1, y2, i, t, n, m, k, q, x[MAXN+1], y[MAXN+1];
    scanf("%d",&t);
    while(t--)
    {
        memset(x, 0, sizeof(x));
        memset(y, 0, sizeof(y));
        scanf("%d%d%d%d",&n,&m,&k,&q);
        while(k--)
        {
            scanf("%d%d",&cx,&cy);
            x[cx] = 1;
            y[cy] = 1;
        }
        for(i=2; i<=n; ++i)
            x[i] += x[i-1];
        for(i=2; i<=m; ++i)
            y[i] += y[i-1];
        while(q--)
        {
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if(x2-x1+1 == x[x2]-x[x1-1] || y2-y1+1 == y[y2]-y[y1-1])
                puts("Yes");
            else
                puts("No");
        }
    }
    return 0;
}



转载于:https://www.cnblogs.com/junior19/p/6730098.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值