hdu5480 简单前缀和

Conturbatio

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1235    Accepted Submission(s): 573


Problem Description
There are many rook on a chessboard, a rook can attack the row and column it belongs, including its own place.

There are also many queries, each query gives a rectangle on the chess board, and asks whether every grid in the rectangle will be attacked by any rook?
 

Input
The first line of the input is a integer T , meaning that there are T test cases.

Every test cases begin with four integers n,m,K,Q .
K is the number of Rook, Q is the number of queries.

Then K lines follow, each contain two integers x,y describing the coordinate of Rook.

Then Q lines follow, each contain four integers x1,y1,x2,y2 describing the left-down and right-up coordinates of query.

1n,m,K,Q100,000 .

1xn,1ym .

1x1x2n,1y1y2m .
 

Output
For every query output "Yes" or "No" as mentioned above.
 

Sample Input
  
  
2 2 2 1 2 1 1 1 1 1 2 2 1 2 2 2 2 2 1 1 1 1 2 2 1 2 2
 

Sample Output
  
  
Yes No Yes
Hint
Huge input, scanf recommended.
 

Source

BestCoder Round #57 (div.2) 

思路:

车能覆盖的所给的矩形的每个各自,那么必须是要么行全覆盖要么列全覆盖,所以先标记有车的行和列,用前缀和算出到哪一行或哪一列有多少车,这样询问时可直接使用。

#include<cstdio>
#include<cstring>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=100010;
int x[maxn],y[maxn];
int n,m,k,q;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d%d",&n,&m,&k,&q);
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		int c,l;
		for(int i=0;i<k;i++)
		{
			scanf("%d%d",&c,&l);
			x[c]=1;
			y[l]=1;
		}
		for(int i=1;i<=maxn;i++)
		{
			x[i]+=x[i-1];
			y[i]+=y[i-1];
		}
		int x1,x2,y1,y2;
		for(int i=0;i<q;i++)
		{
			scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
			if(x[x2]-x[x1-1]==x2-x1+1||y[y2]-y[y1-1]==y2-y1+1)
				puts("Yes");
			else puts("No");
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值