HDU_1068_Girls and Boys_二分图匹配

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10132    Accepted Submission(s): 4660


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

 

Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
 

 

Sample Output
5 2
 
复习了一下匈牙利算法。
之前用以为是并查集,最后发现不对,看题解说是二分匹配,但也没看出为什么是二分匹配。
然后看到了重点,也是今天图论课上学的αº+βº=n(点覆盖数+点独立数=顶点数,又有点覆盖数=二分最大匹配)
最大匹配,即图中最大边独立集。点覆盖数,即用最少的点覆盖所有的边。二分图的最大匹配数等于最小覆盖数,即求最少的点使得每条边都至少和其中的一个点相关联,很显然直接取最大匹配的一端节点即可。
匈牙利算法还需熟悉。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;


int map[1005][1005],t;
int link[1005],vis[1005];

int dfs(int x)
{
    for(int i=0; i<t; i++)
        if(map[x][i]==1)
            if(vis[i]==0)
            {
                vis[i]=1;
                if(link[i]==-1||dfs(link[i]))
                {
                    link[i]=x;
                    return 1;
                }
            }
    return 0;
}

int solve()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0; i<t; i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            ans++;
    }
    return ans;
}
int main()
{
    while(scanf("%d",&t)!=EOF)
    {
        memset(map,0,sizeof(map));
        for(int i=0; i<t; i++)
        {
            int n,n1,num;
            scanf("%d: (%d)",&n1,&n);
            for(int j=0; j<n; j++)
            {
                scanf("%d",&num);
                map[i][num]=1;
            }
        }
        int ans=solve();
        //cout<<ans<<endl;
        printf("%d\n",t-ans/2);
    }
    return 0;
}
View Code

 

转载于:https://www.cnblogs.com/jasonlixuetao/p/5564509.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值