Java练习 SDUT-1131_最大公约数与最小公倍数

C/C++训练1---最大公约数与最小公倍数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

输入两个正整数,求它们的最大公约数与最小公倍数。

Input

输入两个正整数,两个整数之间用空格分开。

数据保证在 int 范围内。

Output

第一行输出最大公约数;
第二行输出最小公倍数。

答案保证在 int 范围内。

Sample Input

64 48

Sample Output

16
192

辗转相除法求最大公因数,不过被要求用类来做,感觉有点麻烦了。

import java.util.*;

public class Main{
    public static void main(String[] args) {
        int a,b,c,d;
        node t;
        Scanner cin = new Scanner(System.in);
        a = cin.nextInt();
        b = cin.nextInt();
        t = new node(a,b);
        c = t.f(a,b);
        d = a * b / c;
        System.out.println(c);
        System.out.println(d);
        cin.close();
    }
}

class node
{
    int a,b;
    node (int x,int y)
    {
        a = x;
        b = y;
    }
    int f(int a,int b)
    {
        if(b==0)
            return a;
        else
            return f(b,a%b);
    }
//      int f(int a,int b)  //两种方法写;
//  {
//      while(b!=0)
//      {
//          int c = b;
//          b = a % b;
//          a = c;
//      }
//      return a;
//  }
}

转载于:https://www.cnblogs.com/luoxiaoyi/p/9758544.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值