R1:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
multilink bundle-name authenticated
!        
archive
 log config
  hidekeys
!
interface FastEthernet0/0
 ip address 100.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 192.168.1.205 255.255.255.0
 speed auto
 full-duplex
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!        
no ip http server
!
!
!
!
control-plane
!
dial-peer voice 100 voip
 destination-pattern 2...
 session target ipv4:192.168.18.120
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
gatekeeper
 shutdown
!
telephony-service
 max-ephones 5
 max-dn 10
 ip source-address 100.1.1.1 port 2000
 auto assign 1 to 2
 timeouts interdigit 2
 max-conferences 8 gain -6
 web admin system name admin secret 5 $1$b9F5$TX/7Xx6U60VnbNBgoCxyw1
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
ephone-dn  1  dual-line
 number 1001
!
ephone-dn  2  dual-line
 number 1002
!
ephone  2
 mac-address 0200.4C4F.4F50
 type CIPC
 button  1:1
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R2:

version 12.4
R2#sh run
*Mar  1 01:29:39.479: %SYS-5-CONFIG_I: Configured from console by console
R2#sh run
Building configuration...

Current configuration : 2099 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
multilink bundle-name authenticated
!        
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  registrar server
!
voice register global
 mode cme
 source-address 192.168.18.120 port 5060
 timeouts interdigit 2
 max-dn 10
 max-pool 5
 authenticate register
 create profile sync 0002746203300359
!
voice register dn  1
 number 2001
 name iphone
!
voice register dn  2
 number 2002
 name iphone4s
!
voice register pool  1
 id mac 2222.2222.2222
 number 1 dn 1
 username 2001 password 2001
 codec g711ulaw
!
voice register pool  2
 id mac 1111.1111.1111
 number 1 dn 2
 username 2002 password 2002
 codec g711ulaw
!
application
  service aa flash:its-CISCO.2.0.1.0.tcl
  param operator 2001
  paramspace english index 1
  paramspace english language en
  paramspace english location flash:
  param max-extension-length 4
  param aa-pilot 2001
  param welcome-prompt en_welcome.au
  !
archive
 log config
  hidekeys
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.18.120 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
no ip http server
ip http path flash:
control-plane


dial-peer voice 100 voip
 service aa
 destination-pattern 1...
 session target ipv4:100.1.1.1
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end