UVA 10042 Smith Numbers(数论)

Smith Numbers

Background

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University , noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:

\begin{displaymath}4937775 = 3\cdot 5\cdot 5\cdot 65837\end{displaymath}

The sum of all digits of the telephone number is4+9+3+7+7+7+5=42, and the sum of the digits of its prime factors is equally3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this type of numbers after his brother-in-law: Smith numbers.

As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number and he excluded them from the definition.

Problem

Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However, Wilansky was not able to give a Smith number which was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers which are larger than 4937775.

Input

The input consists of several test cases, the number of which you are given in the first line of the input.

Each test case consists of one line containing a single positive integer smaller than 109.

Output

For every input value n, you are to compute the smallest Smith number which is larger than nand print each number on a single line. You can assume that such a number exists.

Sample Input

1
4937774

Sample Output

4937775
题意:假设一个合数的各个数字之和等于该数全部素因子的各个数字之和,则称这个数是Smith数。

给出一个n,求大于n的最小的Smith数是多少。

分析:对要推断的数进行素因子分解就可以。由于所求数小于 10^9。若一个数是合数,则其素因子至少有一个小于或等于sqrt(10^9)。则可先把2 - sqrt(10^9) 之间的素数保存起来。 
 
  
#include<stdio.h>
#include<string.h>
const int MAXN = 100005;
int vis[MAXN], prime[10000], num;

void get_prime()
{
    num = 0;
    memset(vis, 0, sizeof(vis));
    vis[0] = vis[1] = 1;
    for(int i = 2; i < MAXN; i++)
    {
        if(!vis[i])
        {
            prime[num++] = i;
            for(int j = i + i; j < MAXN; j += i)
                vis[j] = 1;
        }
    }
}

bool is_prime(int x)
{
    if(x == 0 || x == 1) return false;
    if(x == 2) return true;
    if(x % 2 == 0) return false;
    for(int i = 3; i * i <= x; i += 2)
        if(x % i == 0)
            return false;
    return true;
}

int sum(int x)
{
    int res = 0;
    while(x)
    {
        res += x % 10;
        x /= 10;
    }
    return res;
}

int main()
{
    get_prime();
    int n, t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i = n + 1; ; i++)
        {
            if(is_prime(i))
                continue;
            int s = 0, tmp = i, tmpsum = sum(i);
            for(int j = 0; j < num; j++)
            {
                if(tmp % prime[j] == 0)
                {
                    while(tmp % prime[j] == 0)
                    {
                        s += sum(prime[j]);
                        tmp /= prime[j];
                    }
                    if(is_prime(tmp))
                    {
                        s += sum(tmp);
                        break;
                    }
                }
            }
            if(tmpsum == s)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值