hdu 5334 MZL's xor

hdu 5334 的传送门

MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
The xor of an array B is defined as B1 xor B2…xor Bn

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z) mod l
1≤m,z,l≤5∗105,n=5∗105

Output
For every test.print the answer.

Sample Input
2
3 5 5 7
6 8 8 9

Sample Output
14
16

题目大意: 就是给你一个t表示有t组数据,然后有四个数,n表示最多有几个,也就是i的上限,其余的都在公式里,然后让你求所有和的异或(a[i] 和 a[j]);
解题思路:其实和的异或只有i == j 的时候异或可以,别的都相等,比如说,
当n==3 的时候,有{a[1]+a[2], a[1]+a[3], a[2]+a[3], a[2]+a[1]}——(1);
{ a[3]+a[1], a[3]+a[2]}————(2);
(a[1]+a[1], a[2]+a[2], a[3]+a[3])———(3);
(1) 和 (2) 的异或值是0,所以就只剩下(3)了,明白这一点就好做了,,
下面上代码:

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
int main()
{
    int n,m,z,l,t;
    cin>>t;
    while(t--)
    {
        scanf("%d%d%d%d",&n, &m, &z, &l);
        int ans=0;
        int a=0;
        for(int i=0; i<n; i++)
        {
            a=a^(ans*2);//也就是a^=(ans+ans)
            ans=((LL)ans*m+z)%l;
        }
        cout<<a<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值