CCPC Sudoku

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
Submit Status

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input

The first line of the input gives the number of test cases, T(1T100). T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of 1234). * represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.

Output

For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

Sample input and output

Sample InputSample Output
3

****
2341
4123
3214

*243
*312
*421
*134

*41*
**3*
2*41
4*2*
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

Source

The 2015 China Collegiate Programming Contest
 
题意: 一个4*4的小矩形 有数字和‘*’号 现在要求把‘*’号替换成数字并满足 “数独” 的要求!!!!!
#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int oo = 1e9+7;
const int maxn = 3*1e6+7;
typedef long long LL;
char maps[20][20];
int column[20][20], row[20][20]; ///分别标记列和行 没有被用到的数字
int judge1()///判断行和列是否符合
{
    int i, j, vis[20], num;
    for(i = 0; i < 4; i++)
    {
        memset(vis, 0, sizeof(vis));
        for(j = 0; j < 4; j++)
        {
            num = maps[i][j]-'0';
            vis[num] = 1;
        }
        for(j = 1; j <= 4; j++)
            if(vis[j] == 0)return 0;
    }
    for(i = 0; i < 4; i++)
    {
        memset(vis, 0, sizeof(vis));
        for(j = 0; j < 4; j++)
        {
            num = maps[j][i]-'0';
            vis[num] = 1;
        }
        for(j = 1; j <= 4; j++)
            if(vis[j] == 0)return 0;
    }
    return 1;
}
int judge2(int sx, int ex, int sy, int ey)///判断小四边形是否符合
{
    int num, i, j, vix[20];
    memset(vix, 0, sizeof(vix));
    for(i = sx; i < ex; i++)
    {
        for(j = sy; j < ey; j++)
        {
            num = maps[i][j]-'0';
            vix[num] = 1;
        }
    }
    for(i = 1; i <= 4; i++)
        if(vix[i] == 0) return 0;
    return 1;

}
void dfs(int x, int y)
{
    if(y == 4)
    {
        y = 0;
        x++;
    }
    if(x == 4)
    {
        if(judge1()&&judge2(0,2,0,2)&&judge2(0,2,2,4)&&judge2(2,4,0,2)&&judge2(2,4,2,4))
        {
            for(int i = 0; i < 4; i++)
                printf("%s\n", maps[i]);
        }
        return ;
    }
    if(maps[x][y] == '*')
    {
        for(int i = 1; i <= 4; i++)
        {
            if(row[x][i]==0&&column[y][i]==0)
            {
                maps[x][y] = i+'0';
                column[y][i] = row[x][i] = 1;
                dfs(x, y+1);
                maps[x][y] = '*';
                column[y][i] = row[x][i] = 0;
            }
        }
    }
    dfs(x, y+1);
}
int main()
{
    int T, i, j, cas = 1, num;
    scanf("%d", &T);
    while(T--)
    {
        memset(column, 0, sizeof(column));
        memset(row, 0, sizeof(row));
        for(i = 0; i < 4; i++)
        {
            scanf("%s", maps[i]);
            for(j = 0; j < 4; j++)
            {
                if(maps[i][j] == '*') continue;
                num = maps[i][j]-'0';
                row[i][num] = 1;
                column[j][num] = 1;
            }
        }
        printf("Case #%d:\n", cas++);
        dfs(0, 0);
    }
    return 0;
}

  

///又搞了一个比较节省时间的、
#include<cstdio>
#include<cstring>
#include<stack>
#include<vector>
#include<queue>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
const int oo = 1e9+7;
const int maxn = 1e6+7;
struct da
{
    int x, y;
} as[1000];
int ok, cnt;
char maps[20][20];
int judge(char ch, int cur)
{
    int i, j;
    for(i = 0; i < 4; i++)
    {
        if(maps[as[cur].x][i] == ch || maps[i][as[cur].y] == ch) return 0;
    }
    int x = as[cur].x/2*2;
    int y = as[cur].y/2*2;
    for(i = 0; i < 2; i++)
    {
        for(j = 0; j < 2; j++)
        {
            if(maps[i+x][j+y] == ch) return 0;
        }
    }
    return 1;
}
void dfs(int x)
{
    int i;
    if(x == cnt)
    {
        ok = 1;
        for(i = 0; i < 4; i++)
            printf("%s\n", maps[i]);
        return ;
    }

    for(i = 1; i <= 4; i++)
    {
        if(judge(i+'0', x) && !ok)
        {
            maps[as[x].x][as[x].y] = i+'0';
            dfs(x+1);
            maps[as[x].x][as[x].y] = '*';
        }
    }
}
int main()
{
    int T, i, j, cas = 1;
    scanf("%d", &T);
    while(T--)
    {
        ok = 0; cnt = 0;
        for(i = 0; i < 4; i++)
        {
            scanf("%s", maps[i]);
            for(j = 0; j < 4; j++)
            {
                if(maps[i][j] == '*')
                {
                    as[cnt].x = i;
                    as[cnt].y = j;
                    cnt++;
                }
            }
        }
        printf("Case #%d:\n", cas++);
        dfs(0);
    }
    return 0;
}

  

转载于:https://www.cnblogs.com/PersistFaith/p/4916272.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值