1、拓扑图

 

 

2、配置详细信息

R1#show run
Building configuration...

Current configuration : 646 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 3.3.3.0 255.255.255.0 23.23.23.3
ip route 23.23.23.0 255.255.255.0 12.12.12.2
ip route 2.2.2.0 255.255.255.0 12.12.12.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


R1#

-------------------------------------

R2#show run
Building configuration...

Current configuration : 612 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 23.23.23.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 1.1.1.0 255.255.255.0 12.12.12.1
ip route 3.3.3.0 255.255.255.0 23.23.23.3
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


R2#

-----------------------------------------------------------

R3#show run
Building configuration...

Current configuration : 646 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 1.1.1.0 255.255.255.0 12.12.12.1
ip route 12.12.12.0 255.255.255.0 23.23.23.1
ip route 2.2.2.0 255.255.255.0 23.23.23.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


R3#

3、实验目的

R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 50/60/63 ms
 

4、递归路由的作用

在网络拓扑发生改变的时候,可以减少静态路由更改的工作量。