HDU1060:Leftmost Digit(数论)

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17765    Accepted Submission(s): 6869


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
 
  
2 3 4
 

Sample Output
 
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L
题意:求N^N的最高位数字。

思路:N^N用科学记数法表示,N^N = (double)a * 10^x,x为N^N的位数减一,用N去表示x显然有x = lg(N^N)向下取整;所以(double)a = N^N / 10^( (int)lg(N^N) ),a的整数部分就是答案,但直接计算会溢出,两边取对数有lg(a) = N*lg(N) - (int)N*lg(N),a = 10^( N*lg(N) - (int)N*lg(N) ),这样就不会溢出了。

# include <stdio.h>
# include <math.h>
int main()
{
    int t, n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double k = n*log10(n);
        k -= (long long)k;
        printf("%lld\n",(long long)pow(10, k));
    }
    return 0;
}



转载于:https://www.cnblogs.com/junior19/p/6730011.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值