HDU 1060 Leftmost Digit (数论)

27 篇文章 0 订阅

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13680    Accepted Submission(s): 5239


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.






题目大意:给正整数n,问n^n的最左面的那位数是多少。


解析:高大上的数论,确实对数学的智商不怎么够用。下为借鉴网上大神的思路:

一个数是由每一位的基数乘以相对应的权值,例如 123456 , 基数"1"的权值为 10^5,  基数 "2" 的权值为 10^4......所以该题要求的就是最高位的基数。
    对 x^x 取对数,得 x* ln( x )/ ln( 10 ), 现假设这个值为 X.abcdeefg   那么 10^X 就是 最高位对应的权值,10^ 0.abcdefg 就是最高位的基数。注意这里得到的并不是一个整数,为什么呢? 因为这里是强行将后面位的值也转化到最高位上来了,这有点像大数中,如果不满进制却强行进位,显然那样会进给高位一个小数而不是一个天经地义的整数。得到 10^ 0.abcdefg 后,再用 double floor ( double ) 函数取下整就得到最高位的数值大小了


详解请参见博客: http://www.cnblogs.com/jackge/archive/2013/01/03/2842830.html





AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main(){
//    freopen("in.txt", "r", stdin);
    int t, n;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        double foo = n * log10(double(n));       //需强转
        double ans = foo - floor(foo);
        printf("%d\n", (int)pow(10.0, ans));
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值