POJ 1315

Description

In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4x4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 
Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration. 

Input

The input contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer n that is the size of the board; n will be at most 4. The next n lines each describe one row of the board, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input.

Output

For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

思路就是dfs+回溯,但是回溯时候标记的消去要注意,别把上层或上层以上的标记消去。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<stdlib.h>
#include<map>
#include<vector>
#include<queue>
#include<set>
#include<ctype.h>
#define zuida 100000
using namespace std;
#define INF 0x3f3f3f3f
char zh[10][10];
int vis[10][10];
int maxn=0;int n;
void dfs(int a,int b,int c)
{
    int i,j;
    maxn=max(maxn,c);
    for(i=a;i<n;i++)
    for(j=0;j<n;j++)
    {
        if(zh[i][j]=='.'&&!vis[i][j])
        {
            int k;
            for(k=i;k<n;k++)
            {
                if(zh[k][j]=='X')break;
                vis[k][j]++;
            }
            for(k=i;k>=0;k--)
            {
                if(zh[k][j]=='X')break;
                vis[k][j]++;
            }
            for(k=j;k<n;k++)
            {
                if(zh[i][k]=='X')break;
                vis[i][k]++;
            }
            for(k=j;k>=0;k--)
            {
                if(zh[i][k]=='X')break;
                vis[i][k]++;
            }

            dfs(i,j,c+1);

            for(k=i;k<n;k++)
            {
                if(zh[k][j]=='X')break;
                vis[k][j]--;
            }
            for(k=i;k>=0;k--)
            {
                if(zh[k][j]=='X')break;
                vis[k][j]--;
            }
            for(k=j;k<n;k++)
            {
                if(zh[i][k]=='X')break;
                vis[i][k]--;
            }
            for(k=j;k>=0;k--)
            {
                if(zh[i][k]=='X')break;
                vis[i][k]--;
            }

        }
    }
}
int main()
{

    while(cin>>n&&n)
    {
        maxn=0;
        int i,j;
        memset(vis,0,sizeof(vis));
        for(i=0;i<n;i++)
        {
            getchar();
            for(j=0;j<n;j++)
            cin>>zh[i][j];
        }
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                dfs(i,j,0);
        cout<<maxn<<endl;
    }
}

大佬标记的简化用了一个函数

const int Dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};  
  
int N,Ans,HashMap[10][10];  
  
char Map[10][10];  
  
void UpdateHashMap(int Row,int Col,int Val)  
{  
    for(int n=0;n<4;++n)  
    {  
        int tmprow=Row;  
        int tmpcol=Col;  
        while(1)  
        {  
            if(!(0<=tmprow&&tmprow<N))   { break; }  
            if(!(0<=tmpcol&&tmpcol<N))   { break; }  
            if(Map[tmprow][tmpcol]!='.') { break; }  
            HashMap[tmprow][tmpcol]+=Val;  
            tmprow+=Dir[n][0];  
            tmpcol+=Dir[n][1];  
        }  
    }  
}  

 

转载于:https://www.cnblogs.com/SparkPhoneix/p/8782699.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
城市应急指挥系统是智慧城市建设的重要组成部分,旨在提高城市对突发事件的预防和处置能力。系统背景源于自然灾害和事故灾难频发,如汶川地震和日本大地震等,这些事件造成了巨大的人员伤亡和财产损失。随着城市化进程的加快,应急信息化建设面临信息资源分散、管理标准不统一等问题,需要通过统筹管理和技术创新来解决。 系统的设计思路是通过先进的技术手段,如物联网、射频识别、卫星定位等,构建一个具有强大信息感知和通信能力的网络和平台。这将促进不同部门和层次之间的信息共享、交流和整合,提高城市资源的利用效率,满足城市对各种信息的获取和使用需求。在“十二五”期间,应急信息化工作将依托这些技术,实现动态监控、风险管理、预警以及统一指挥调度。 应急指挥系统的建设目标是实现快速有效的应对各种突发事件,保障人民生命财产安全,减少社会危害和经济损失。系统将包括预测预警、模拟演练、辅助决策、态势分析等功能,以及应急值守、预案管理、GIS应用等基本应用。此外,还包括支撑平台的建设,如接警中心、视频会议、统一通信等基础设施。 系统的实施将涉及到应急网络建设、应急指挥、视频监控、卫星通信等多个方面。通过高度集成的系统,建立统一的信息接收和处理平台,实现多渠道接入和融合指挥调度。此外,还包括应急指挥中心基础平台建设、固定和移动应急指挥通信系统建设,以及应急队伍建设,确保能够迅速响应并有效处置各类突发事件。 项目的意义在于,它不仅是提升灾害监测预报水平和预警能力的重要科技支撑,也是实现预防和减轻重大灾害和事故损失的关键。通过实施城市应急指挥系统,可以加强社会管理和公共服务,构建和谐社会,为打造平安城市提供坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值