Java练习 SDUT-2272_Time

Time

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases.
Each case contains 4 integers in a line, separated by space.
Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

1494602-20180927144553421-1870183760.png

一道绘图题,这种题一直是弱项,头铁强制画了出来,浪费了挺多时间。而且整个人都狂燥了。
结果看到这份代码

  • z_xindong的代码
    瞬间清醒了,其实用三维数组存一下就可以了。(String开二维就好)
import java.util.Scanner;
 
public class Main{
 
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
         String[][] time=new String[][]{
                 {" _ ","   "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
                 {"| |","  |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
                 {"|_|","  |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"}};
            
        while(cin.hasNext()){
            int[] a=new int[4];
            for(int i=0;i<4;i++){
                a[i]=cin.nextInt();
            }
            for (int i = 0; i < 3; i++) {
                for (int j = 0; j < 4; j++) {
                    System.out.print(time[i][a[j]]);
                }
                System.out.println();
            }           
        }
    } 
}

转载于:https://www.cnblogs.com/luoxiaoyi/p/9712968.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值