Ningbo [1219] Time(将数字转换成时钟那样的数字)

1、http://cdn.ac.nbutoj.com/Problem/view.xhtml?id=1219

2、比赛的时候居然想了一个小时,才意识到是3*3字符的含义,纠结,好在一遍AC了

题目:

  • [1219] Time

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
  • 输入
  • There are several test cases.
    Each case contains 4 integers in a line, separated by space.
    Proceed to the end of file.
  • 输出
  • For each test case, output the time expressed by the digital clock such as Sample Output.
  • 样例输入
  • 1 2 5 6
    2 3 4 2
  • 样例输出
  •     _  _  _ 
      | _||_ |_ 
      ||_  _||_|
     _  _     _ 
     _| _||_| _|
    |_  _|  ||_ 
  • 提示
  • The digits showed by the digital clock are as follows:
       _  _     _  _  _  _  _  _ 
     | _| _||_||_ |_   ||_||_|| |
     ||_  _|  | _||_|  ||_| _||_|
  • 来源
  • 辽宁省赛2010
3、AC代码:

#include<stdio.h>
#include<math.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int a[5];
int main()
{
    while(scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3])!=EOF)
    {
        for(int i=0; i<3; i++)
        {
            for(int j=0; j<=3; j++)
            {
                if(i==0)
                {
                    if(a[j]==1)
                        printf("   ");
                    else if(a[j]==2)
                        printf(" _ ");
                    else if(a[j]==3)
                        printf(" _ ");
                    else if(a[j]==4)
                        printf("   ");
                    else if(a[j]==5)
                        printf(" _ ");
                    else if(a[j]==6)
                        printf(" _ ");
                    else if(a[j]==7)
                        printf(" _ ");
                    else if(a[j]==8)
                        printf(" _ ");
                    else if(a[j]==9)
                        printf(" _ ");
                    else if(a[j]==0)
                        printf(" _ ");

                }
                else if(i==1)
                {
                    if(a[j]==1)
                        printf("  |");
                    else if(a[j]==2)
                        printf(" _|");
                    else if(a[j]==3)
                        printf(" _|");
                    else if(a[j]==4)
                        printf("|_|");
                    else if(a[j]==5)
                        printf("|_ ");
                    else if(a[j]==6)
                        printf("|_ ");
                    else if(a[j]==7)
                        printf("  |");
                    else if(a[j]==8)
                        printf("|_|");
                    else if(a[j]==9)
                        printf("|_|");
                    else if(a[j]==0)
                        printf("| |");
                }
                else if(i==2)
                {
                    if(a[j]==1)
                        printf("  |");
                    else if(a[j]==2)
                        printf("|_ ");
                    else if(a[j]==3)
                        printf(" _|");
                    else if(a[j]==4)
                        printf("  |");
                    else if(a[j]==5)
                        printf(" _|");
                    else if(a[j]==6)
                        printf("|_|");
                    else if(a[j]==7)
                        printf("  |");
                    else if(a[j]==8)
                        printf("|_|");
                    else if(a[j]==9)
                        printf(" _|");
                    else if(a[j]==0)
                        printf("|_|");
                }


            } printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值