hdu3501


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 


Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 


Output
For each test case, you should print the sum module 1000000007 in a line.
 


Sample Input
 
  
3 4 0
 


Sample Output
 
  
0 2
代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1000000007;
int phi(long long m)
{
    long long  rea=m;
    for(long long  i=2;i*i<=m;i++)
     {
         if(m%i==0)
         rea-=rea/i;
         while(m%i==0)
         m/=i;
     }
     if(m>1)
        rea-=rea/m;
     return rea;
}
int main()
{
    /*欧拉函数一个小小的性质:
    求小于n并且与n互质的数的和为:m*phi[m]/2;*/
    long long  m,ans;
    while(~scanf("%lld",&m))
     {
         if(m==0)break;
         ans=phi(m);
         ans=(m*(m-1)/2-m*ans/2)%mod;
         printf("%lld\n",ans);
     }
    return 0;
}#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1000000007;
int phi(long long m)
{
long long rea=m;
for(long long i=2;i*i<=m;i++)
{
if(m%i==0)
rea-=rea/i;
while(m%i==0)
m/=i;
}
if(m>1)
rea-=rea/m;
return rea;
}
int main()
{
/*欧拉函数一个小小的性质:
求小于n并且与n互质的数的和为:n*phi[n]/2;*/
long long m,ans;
while(~scanf("%lld",&m))
{
if(m==0)break;
ans=phi(m);
ans=(m*(m-1)/2-m*ans/2)%mod;
printf("%lld\n",ans);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值