hdu 3501(欧拉函数)

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
0 2
解题思路:
解这道题之前先看一个证明:
给出一个N,求1..N中与N互质的数的和

if gcd(n,i)=1 then gcd(n,n-i)=1 (1<=i<=n)

反证法:
         如果存在K!=1使gcd(n,n-i)=k,那么(n-i)%k==0
         而n%k=0
         那么必须保证i%k=0
         k是n的因子,如果i%k=0那么
 gcd(n,i)=k,矛盾出现;
         于是问题变的非常简单: ANS=N*phi(N)/2
         i,n-i总是成对出现,并且和是n
这道题是求与N非互质的数之和,那么1到N-1的和(因为不能有N)减去ANS即是答案。。
AC:
#include<iostream>
#include<cstdio>
using namespace std;

typedef __int64 LL;
const int mod = 1000000007;
LL euler(LL n)
{
	LL res = n;
	for(int i = 2; i * i <= n; i++)
	{
		if(n % i == 0)
		{
			res = res / i * (i - 1);
			while(n % i == 0)
				n /= i;
		}
	}
	if(n > 1) res = res / n * (n - 1);
	return res;
}

int main()
{
	LL n;
	while(scanf("%I64d",&n)!=EOF && n)
	{
		if(n == 1)
		{
			printf("0\n");
			continue;
		}
		LL num = euler(n);  //与n互质的个数
		LL sum = ((n-1)*n/2 - num*n/2)%mod;
		printf("%d\n",sum);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值