HDU5188:zhx and contest(类01背包)

zhx and contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 828    Accepted Submission(s): 316


Problem Description
As one of the most powerful brushes in the world, zhx usually takes part in all kinds of contests.
One day, zhx takes part in an contest. He found the contest very easy for him.
There are  n problems in the contest. He knows that he can solve the  ith problem in  ti units of time and he can get  vi points.
As he is too powerful, the administrator is watching him. If he finishes the  ith problem before time  li, he will be considered to cheat.
zhx doesn't really want to solve all these boring problems. He only wants to get no less than  w points. You are supposed to tell him the minimal time he needs to spend while not being considered to cheat, or he is not able to get enough points. 
Note that zhx can solve only one problem at the same time. And if he starts, he would keep working on it until it is solved. And then he submits his code in no time.
 

Input
Multiply test cases(less than  50). Seek  EOF as the end of the file.
For each test, there are two integers  n and  w separated by a space. ( 1n30 0w109)
Then come n lines which contain three integers  ti,vi,li. ( 1ti,li105,1vi109)
 

Output
For each test case, output a single line indicating the answer. If zhx is able to get enough points, output the minimal time it takes. Otherwise, output a single line saying "zhx is naive!" (Do not output quotation marks).
 

Sample Input
 
  
1 3 1 4 7 3 6 4 1 8 6 8 10 1 5 2 2 7 10 4 1 10 2 3
 

Sample Output
 
  
7 8 zhx is naive!
 

Source

题意:略。

HINT:第一组数据,第6s时开始做,第7s完成。第二组数据,第1s时做第3题,第4s时做第1题,第8s时完成。

思路·:由于限制了做题时间,需要排一下序,将先做的题放到前面再用01背包解法。

# include <stdio.h>
# include <string.h>
# include <algorithm>
# define MAXN 100000
using namespace std;
int dp[MAXN*30+1];
struct node
{
    int t, v, l;
}a[31];
int cmp(node a, node b) {return a.l-a.t < b.l-b.t;}
int main()
{
    int n, w, totalv, totalt, maxl, max_v;
    while(~scanf("%d%d",&n,&w))
    {
        totalt = totalv = maxl = 0;
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d%d",&a[i].t, &a[i].v, &a[i].l);
            totalt += a[i].t;
            totalv += a[i].v;
            maxl = max(maxl, a[i].l);
        }
        if(totalv < w)
        {
            puts("zhx is naive!");
            continue;
        }
        max_v = max(totalt, maxl);
        sort(a, a+n, cmp);
        memset(dp, 0, sizeof(dp));
        for(int i=0; i<n; ++i)
            for(int j=max_v; j>=a[i].l && j>=a[i].t; --j)
                dp[j] = max(dp[j], dp[j-a[i].t]+a[i].v);
        for(int i=0;;++i)
            if(dp[i] >= w)
            {
                printf("%d\n",i);
                break;
            }
    }
    return 0;
}


转载于:https://www.cnblogs.com/junior19/p/6730059.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值