【2136】数据结构实验之二叉树的建立与遍历 SDUTOJ



数据结构实验之二叉树的建立与遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后方式遍历二叉树最后求出叶子节点个数和二叉树深度

输入

  输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfa
cgefdba
3
5
 
  
 
  
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a=0,b=0;
struct node
{
    char str;
    struct node *left,*right;
}*p;
struct node *creat(struct node *p)//先序建立二叉树
{
    char ch;
    scanf("%c",&ch);
    if(ch==',')
        p=NULL;
    else
    {
        p=(struct node *)malloc(sizeof(struct node));
        p->str=ch;
        p->left=creat(p->left);
        p->right=creat(p->right);
    }
    return p;
};
void zhongxu(struct node *p)//中序遍历序列输出
{
    if(p!=NULL)
    {
        zhongxu(p->left);
        printf("%c",p->str);
        zhongxu(p->right);
    }
}
void houxu(struct node *p)//后续遍历序列输出
{
    if(p!=NULL)
    {
        houxu(p->left);
        houxu(p->right);
        printf("%c",p->str);
    }
}
int yezi(struct node *p)//求叶子个数的函数
{
    if(p!=NULL)
    {
        if(p->left==NULL&&p->right==NULL)
            a++;
        yezi(p->left);
        yezi(p->right);
    }
    return a;
}
int deep(struct node *p)//求二叉树深度的函数
{
    int l,r;
    if(!p)
       return 0;
    l=deep(p->left);
    r=deep(p->right);
    return l>r?l+1:r+1;
}
int main()
{
    int n;
    struct node *root;
    root=creat(p);
    zhongxu(root);
    printf("\n");
    houxu(root);
    printf("\n");
    printf("%d\n",yezi(root));
    printf("%d\n",deep(root));
    return 0;
}
 

转载于:https://www.cnblogs.com/jiangyongy/p/3971661.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值