遍历二叉树
Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序、后序和层序的方式遍历该二叉树。
Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output
每组输入数据对应输出2行:
第1行输出中序遍历序列;第2行输出后序遍历序列;第3行输出层序遍历序列。
每组输入数据对应输出2行:
第1行输出中序遍历序列;第2行输出后序遍历序列;第3行输出层序遍历序列。
Example Input
abc,,de,g,,f,,,
Example Output
cbegdfa cgefdba abcdefg
代码如下:
<span style="font-weight: normal;">#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
int data;
struct node *l,*r;
};
#define x (struct node *) malloc (sizeof(struct node));
char s[55];
int i;
struct node* Creat()
{
struct node *root;
char c=s[i++];
if(c==',') return NULL;
else
{
root=x;
root->data=c;
root->l=Creat();
root->r=Creat();
}
return root;
}
void zhongxv(struct node *root)//中序遍历
{
if(root)
{
zhongxv(root->l);
printf("%c",root->data);
zhongxv(root->r);
}
}
void cengxv(struct node *root)//层序遍历
{
struct node *q[1111];
int in=0,out=0;
q[in++]=root;
while(in>out)
{
if(q[out])
{
printf("%c",q[out]->data);
q[in++]=q[out]->l;
q[in++]=q[out]->r;
}
out++;
}
}
void houxv(struct node *root)//后序遍历
{
if(root)
{
houxv(root->l);
houxv(root->r);
printf("%c",root->data);
}
}
int main()
{
while(~scanf("%s",s))
{
i=0;
struct node *root=Creat();
zhongxv(root);
printf("\n");
houxv(root);
printf("\n");
cengxv(root);
printf("\n");
}
return 0;
}</span>