遍历二叉树

遍历二叉树

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序、后序和层序的方式遍历该二叉树。

Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output

每组输入数据对应输出2行:
第1行输出中序遍历序列;第2行输出后序遍历序列;
第3行输出层序遍历序列。

Example Input
abc,,de,g,,f,,,
Example Output
cbegdfa
cgefdba
abcdefg
代码如下:
<span style="font-weight: normal;">#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
    int data;
    struct node *l,*r;
};
#define x (struct node *) malloc (sizeof(struct node));
char s[55];
int i;
struct node* Creat()
{
    struct node *root;
    char c=s[i++];
    if(c==',') return NULL;
    else
    {
        root=x;
        root->data=c;
        root->l=Creat();
        root->r=Creat();
    }
    return root;
}
void zhongxv(struct node *root)//中序遍历
{
    if(root)
    {
        zhongxv(root->l);
        printf("%c",root->data);
        zhongxv(root->r);
    }
}
void cengxv(struct node *root)//层序遍历
{
    struct node *q[1111];
    int in=0,out=0;
    q[in++]=root;
    while(in>out)
    {
        if(q[out])
        {
            printf("%c",q[out]->data);
            q[in++]=q[out]->l;
            q[in++]=q[out]->r;
        }
        out++;
    }
}
void houxv(struct node *root)//后序遍历
{
    if(root)
    {
        houxv(root->l);
        houxv(root->r);
        printf("%c",root->data);
    }
}
int main()
{
    while(~scanf("%s",s))
    {
        i=0;
        struct node *root=Creat();
        zhongxv(root);
        printf("\n");
        houxv(root);
        printf("\n");
        cengxv(root);
        printf("\n");
    }
    return 0;
}</span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值