p_w_picpath

 

 

R1:

ipv6 unicast-routing
!        
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::1/64
!
ipv6 route ::/0 12::2

 

R2:
 

ipv6 unicast-routing
!        
interface Loopback0
ip address 10.1.1.2 255.255.255.255
!        
interface Tunnel0
no ip address
no ip redirects
ipv6 address 2001:1::/64 eui-64 //给隧道接口配置一个64位的前缀,并使用参数EUI-64让路由器生成地址的后半部分(接口ID),路由器将第5-6个编组设置为0000:5EFE,CA01:101为f1/0口IPv4地址202.1.1.1的十六进制形式

p_w_picpath
tunnel source FastEthernet1/0
tunnel mode ipv6ip isatap  //定义隧道模式为ISATAP
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 12::2/64
!
interface FastEthernet1/0
ip address 202.1.1.1 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 202.1.1.254
!
ipv6 route 45::/64 2001:1::5EFE:4001:101 //指定下一跳为对端tunnel口地址

 

R3:

interface FastEthernet0/0
ip address 202.1.1.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 64.1.1.254 255.255.255.0
duplex auto
speed auto

 

R4:

ipv6 unicast-routing
!        
interface Loopback0
ip address 10.1.1.4 255.255.255.255
!        
interface Tunnel0
no ip address
no ip redirects
 ipv6 address 2001:1::/64 eui-64

p_w_picpath
tunnel source FastEthernet0/0
tunnel mode ipv6ip isatap
!
interface FastEthernet0/0
ip address 64.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 45::4/64
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 64.1.1.254
!
ipv6 route 12::/64 2001:1::5EFE:CA01:101

 

R5:

ipv6 unicast-routing
!        
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 45::5/64
!
ipv6 route ::/0 45::4

p_w_picpath

p_w_picpath