NUC1011 Financial Management【数学计算】

Financial Management

时间限制: 1000ms 内存限制: 10000KB
问题描述
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
输入描述
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
输出描述
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
样例输入
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
样例输出
$1581.42
来源
{Mid-Atlantic 2001}


问题分析:(略)

这个问题和《UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management【数学计算】》是同一个问题,代码拿过来用就AC了。

程序说明:参见参考链接。

参考链接:UVALive2362 POJ1004 HDU1064 ZOJ1048 Financial Management【数学计算】

题记:程序做多了,不定哪天遇见似曾相识的。

AC的C++程序如下:

/* UVALive2362 Financial Management */

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    double val, sum;

    sum = 0;
    for(int i=1; i<=12; i++) {
        cin >> val;
        sum += val;
    }

    printf("$%.2f\n", sum / 12);

    return 0;
}




转载于:https://www.cnblogs.com/tigerisland/p/7563685.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值